2

I wanted to get into Xamarin, but I have a problem. Whenever I try to run any of the settings in the android emulator, the warning "You do not have permission to modify internal Hyper-V network adapter settings" pop-up. Since I have the admin rights, I just click "Retry"(with admin rights). However, after I click the "Retry" button, the emulator gets stuck at "Preparing virtual machine..." .

I've rebooted, reinstalled the emulator, and made sure that Hyper-v was on, yet the problem persists. Also, I am in the Hyper-V admin group, DNS is automatically configured, DHCP is enabled, and (not sure if this changes anything, but) I use VPN. I don't want to turn Hyper-V off. How can I get the emulator to run? Thanks in advance.

EDIT:actually, I do not see emulator option that begin from vsemulator in visual studio. Does that mean the emulator is not properly installed?

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.