1

I know this question has been asked a million times before this, but I can't find any suitable answer so please bear with me.

In brief: I want to dual-boot Ubuntu 14.04 and Windows 7 Ultimate. There was a slight hiccup at the fact that I had Ubuntu installed first, but I managed to handle that. I have 450 GBs of space on a partition on my HDD in NTFS (this is the partition where I want to install Windows). My HDD has been GPT since the start and my motherboard (MSI 970 Gaming) definitely supports UEFI+Legacy. So everything is okay on that front, but the windows installer still warned "The selected disk is of GPT partition style."

After asking around on some Ubuntu forums, I was told there is something called IOMMU that has to be enabled, and that its supposed to be available on the 970 chipset, but I couldn't find that option in my BIOS (MSI click BIOS 4). After further research I came to know some motherboard manufacturers choose not to include that option and I chose to go with that explanation (please correct me here if I can't see big red buttons screaming "IOMMU").

I have backed up all my Ubuntu data and formatting the entire disk is an option that can be availed of, but I would prefer not to have it that way. Additonally, I want to actually get Windows 7 to work with GPT rather than just re-formatting the whole drive to MBR and calling it a day. An Ubuntu live USB is also something that can be used if required (I have one at ready).

I don't understand what I'm doing wrong. Please help me out of this spot of bother.

Thanks

19
  • but it still threw the same error...what error? The selected disk is of GPT partition style? If so, please edit your question to make that more obvious. Feb 16 '17 at 22:25
  • @Twisty yes that error. I'll fix it.
    – Rushat
    Feb 17 '17 at 11:27
  • you're not trying to install a 32-bit win7 are you? that seems possible (read: isn't supported)
    – quixotic
    Feb 17 '17 at 11:37
  • @quixotic no its definitely 64bit
    – Rushat
    Feb 17 '17 at 11:47
  • 1
    The Windows DVD will boot in either UEFI or Legacy mode so that, for most motherboards, and depending on the BIOS settings, you might see two boot options like: "UEFI DVD drive" and just "DVD drive" for the same drive/disc. For USB however, it needs to be made UEFI bootable. If the USB media is NTFS formatted, an UEFI installation is not possible. It needs to be FAT32 formatted. Could you check the file system of the installation media? Feb 21 '17 at 13:30
3

I have 450 GBs of space on a partition on my HDD in NTFS (this is the partition where I want to install Windows).

This is likely the problem. EFI boots from a file on the EFI system partition (basically a FAT32 boot partition). You need space on your harddisk to create that. Wipe the NTFS partition, reboot and boot from a win7 x64 DVD in UEFI mode and you should not have any problems.


Having said that, some background:

1 EFI installs - generic.

UEFI firmware boots from a file from an EFI system partition. It need to be able to read from that partition. EFI is guaranteed to understand FAT32 (and basically only that unless you have an Apple). It needs to be told which file to boot. if it is not it will fall back to \efi\boot\bootx64.EFI

2 Windows 7 x64 and UEFI:

The Windows 7 x64 installation DVD has two choices with regards to UEFI/GPT.

  1. Boot in legacy mode (either from a BIOS or from an EFI with the compatability shims enable. Basically booting from EFI in BIOS mode).
  2. Boot in EFI mode.

Windows 7 x64 supports both of these options. However if you boot in BIOS (or CSM) mode then it will only install to a MBR formatted disk. If your disk is already partitioned using the GPT scheme it will throw the error The selected disk is of GPT partition style.

That leaves you two options:

  1. Wipe the disk, repartition with MBR. Use legacy modes.
  2. Boot the DVD in EFI mode. The windows 7 x64 DVD supports this.
    Sidenote: Installling windows 7 from an USB pendrive in EFI mode requires a bit more work. The pendrive must be FAT32 formatted and it must contain the .EFI bootfile. The way I usually do this is locating bootmgfw.efi on my current windows 7 desktop and moving (and renaming) it to \efi\boot\bootx64.EFI on the pendrive.

3: IO MMU

As Mirh wrote an IOMMU is a virtualization thing. it is relevant if you boot another OS (e.g. Ubuntu) and when you want to start a second OS from inside Ubuntu. E.g. by running vmware player or virtualbox. With some effort that can give that guest OS raw access to hardware. This would allow you to run Ubuntu and at the same time run a game in windows using direct graphics hardware. It is an intersting topic, but it has nothing to do with installing windows.

4 Some notes

No bootsector is required to boot in EFI mode. For clean EFI install I find it best to only offer the EFI boot method. This way you will at least be sure which mode the system booted in.
If the system fails to boot after you turned CSM off then it was using the old BIOS method.

You can check in whiuch mode you booted. When you arrive at the install screen press SHIFTF10 and type notepad \Windows\Panther\setupact.log. It should read "Callback_BootEnvironmentDetect: Detected boot environment: UEFI"

Last note: (already made in the text but worth repeating). If using a pen drive or USb disk it must be in a format which EFI supports. FAT32 is guaranteed to work. NTFS does not work.
(If it was not for Apple and HFS+EFI then I could simplify this to: Only use FAT32, ever).

3
  • Hi, thanks for your answer :). I had, in fact, tried the partition in FAT32 originally before I had formatted to NTFS. In FAT32, however, the windows 7 installer told me that it won't install on FAT32. I searched about this further on the net and found that windows 7 only works on NTFS.
    – Rushat
    Feb 26 '17 at 4:43
  • The OS itself wants NTFS, the 'bootloader' does not. It is either as a real bootloader in the classical sense, triggered from code in the partition table, or an EFI file on the ESP. That Efi System Partition must be FAT32. So you have two partitions. One small on being FAT32 and a larger one being NTFS.
    – Hennes
    Feb 26 '17 at 12:51
  • Minor update. You might have at least two partitions. Since you already have Ubuntu you are bound to have a few more. And even a clean install of windows might generate more than two. E.g. recovery partitions on win8+, or microsoft reserved partitions.
    – Hennes
    Feb 26 '17 at 12:53
2

IOMMU is a virtualization thing, it has nothing to do with this.

More likely, you are booting Windows installer in legacy mode. And given you need UEFI to boot from GPT, it thinks your computer lacks it.

Ideally, given your motherboard is similarly aged to my laptop, you should see UEFI: My usb disk at boot device selection. Otherwise you probably flashed the ISO incorrectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.