0

I was trying to increase size of /dev/sda1 in VMware workstation, and followed a suggestion to unmount /dev/sda1, becuse of error "device busy".

so i umounted and now i can't boot it.

i get "Operating System not found"

The host is windows 10, guest is Ubuntu 16 (command line, no GUI)

How can i mount back sda1?

Maybe i can boot VMware instance via LiveCD and do something there?

EDIT
I started from iso and created partition from fdisk so now i can access shell and /dev/sda1 from rescue console.

But original install still doesn't boot.

EDIT 2
I marked sda1 as Boot * but it still not boot the guest.

In rescue console i can Reinstall GRUB boot loader. Should i try it or can it destroy data on disk?

  • When you say that you "can't boot it", what exactly does "it" refer to? The host or the guest? – a CVn Feb 17 '17 at 14:56
  • @MichaelKjörling the guest – Mike Feb 17 '17 at 15:01
0

So i did this:

I set up VMware workstation to boot from Ubuntu Server Iso. (DVD/CD settings)
Then (after language choice), there is menu "Rescue the system"

Warning:
Before unmounting i had 3 partitions: sda1, sda2,sda5.
Sda5 was my swap partition and doing steps below left
drive without it.

I lanuched console, fdisk /dev/sda.
Then in fdisk console:
n (new partition)
1 (first partition)
default
default
a (to mark as boot)

I'm not sure if above part was required.

Then i downloaded a Desktop iso of Ubuntu and launched it as Try Ubuntu

Then i installed boot-repair as documented here: https://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/

Then i set back DVD/CD back to detect drive and Vmware system boots up.

Adding swap Since unmounting and mounting like above took all available space i had to create another partition for Swap. I added disk data via Vmware and then followed this instructions https://askubuntu.com/questions/180730/how-do-i-restore-a-swap-partition-i-accidentally-deleted

Additional info
After doing above i couldn't launch back from cd (it booted to drive immediately).

The option is to boot to Bios https://superuser.com/a/940436/664498, and setup launch from CDROM as first, then drive.

  • You should have been able to rescue your system by booting the Ubuntu 16 ISO from the CD-ROM, then recovering your sda1 with testdisk. After that you can move your partition boundaries with gparted and use boot-repair to regenerate the grub data. You would then not need to boot via a CD-ROM image. – AFH Feb 17 '17 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.