I'm using my CPU, memory and board with the default, spec-defined voltages and frequencies. Yet if I run Memtest 5.01 (which installs alongside my Linux Mint 18) in SMP mode, my machine hangs at some point in the beginning of test #5. I can complete a pass in single-core mode; and I tried about 30 minutes of stress-ng.

Now, this is a new CPU, memory and board, so while it's possible there's some issue with them, it's not very likely. On the other hand, I have read here and there that MemTest+5.01 might fail. Also, I just found the 5.01 Changelog, which says (emphasis mine):

  • Corrected bugs, bugs and more bugs (some could remain)

... and this certainly does not expire confidence.

I don't want to exceed the scope of this site, but - how should I proceed? That is, should I try to get some alternative memory torture-tester and run that? Should I assume it's a bug? I'm going to write the MemTest author anyway but perhaps other people can share a similar experience.

  • 2
    Without identical modules (multiple sets) I am more likely to lean towards a hardware problem – Ramhound Feb 17 '17 at 19:28
  • @Ramhound: I do have two sets of two identical modules each (but not 4 identical modules)... what do you suggest I do with them? – einpoklum Feb 17 '17 at 20:11
  • You have 8 different combinations, to rule out hardware, you would have to test them all :-$ – Ramhound Feb 17 '17 at 20:32
  • @Ramhound: Including the no-modules option? :-P ... anyway, I'm actually only using 2 of the modules, I only mentioned the other two since you said I needed multiple sets of identical modules. So, you're suggesting I test all 3 possible combinations, right? – einpoklum Feb 17 '17 at 20:37
  • 1
    I am saying verify the problem happens with another set at least – Ramhound Feb 17 '17 at 22:39

I would say it is almost certain that you have...

see this answer Memtest freezing at...

I can confirm that I run into this issue with virtually every machine I test. Lately I have been working with refurbished lenovos of the T5xx range, with various memory and CPU configurations (usually the stock RAM the machine was sold with). I'm up to at least 10 where I've tried the SMP mode -- usually I just let the failsafe mode run 'cause I need to move along.

My hangs seem to occur at varying tests, but the machines always hang. And hang completely - so the keyboard is unresponsive, requiring a power off.

I have just experienced it with a new Zotac SFF PC, with a 4-core Celeron N3150 @1.6 GHz (stock) and 8 GB of Corsair valueselect DDR3L modules (2 modules) CMSO4GX3M1C1600C11

This machine hangs at Test #7 [Block move], same region both times.

The "Fail-safe" mode runs through this test with no problems, and completes with the memory all testing OK.

Interestingly (maybe to the memtest+ devs) the % completion (progress reporting) is different for the SMP and "fail-safe" modes at the point where the SMP run fails.

In this case, the memtest86+ is the one installed with non-uefi xubuntu 16.04.

Any news from the memtest+ developer?

  • No, but frankly I've not had the time to pursue this. – einpoklum Apr 9 '17 at 21:59
  • I have just had a chance to re-test some of the machines I referred to in my above answer, using the memtest installed with a non-uefi xubuntu 18.04, and they all completed using SMP mode. So the version installed with a later version of linux mint may work just fine. Easy to test with a new boot medium (liveCD?). – BISI Jan 2 '19 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.