I have a fresh install of Windows XP.

My problem is that every time I start it up, I have to go into Administrative Tools and start the needed services, such as DCOM, RTP, DHCP, etc. The only services that start automatically are:

  • plug and play
  • remote procedure
  • server
  • windows audio
  • workstation

All of the rest have to be started manually, in spite of the fact that they're listed as automatic startup. Why won't they start on their own, like they should?

  • What do the system and application event logs show? Any errors relating to those services starting? Mar 9, 2010 at 19:48
  • those services are among the services which do not start.
    – Mala
    Mar 9, 2010 at 20:16
  • Have you tried safe mode? (The Event log service and a few others should auto start in safe mode as well). Perhaps try system restore to go back to JUST after the XP install was finished and see how they act? Mar 9, 2010 at 21:28

4 Answers 4


I'd check the Log On as account within each service. Are the services that are starting correctly using the same account as the ones that aren't?

  • i'm not sure, i'll have to check... but these services start if i start them from the Services window in Administrative Tools. In any case, I'll get back to you
    – Mala
    Mar 9, 2010 at 20:17
  • There is no discernible difference - mostly they're all using the system account, and some of those start automatically, but most of them don't
    – Mala
    Mar 9, 2010 at 20:49

If you run msconfig, you can setup the proper services that you need on startup. You should check and make sure that they are enabled there.

You can also run services.msc to get to your services menu, but it sounds like you've already checked that judging by how you say that they're set to automatic.


make sure the msconfig setting check in "Service" tab & StartUP Tab


I figured out what the issue was: Windows had not installed correctly, for one reason or another. While the OS booted and worked for the most part, a lot of things (msconfig itself, for example) were quite simply missing. A reinstall of Windows fixed the problem.

Thanks for your suggestions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.