1

Good morning!

I'm playing with my Raspberry Pi 3 Model B version 2 with openSUSE LEAP 42.2 version (AArch64) in order to install an updated MongoDB version.

The problem is that I'm following the official walkthrough from MongoDB (https://docs.mongodb.com/manual/tutorial/install-mongodb-on-suse/), but I'm unable to install MongoDB 3.4 version.

Once added the repo, when I'm trying to execute "zypper -n install mongodb-org" zypper returns that the package doesn't exist. So, to confirm that, I ran "zypper search mongo" and zypper was right, there's no mongodb packages even after adding the repo.

I tried to repeat the process removing the repo first, but same result. I'm running out of ideas, what's up with zypper? Could you tell me what I'm doing wrong?

Thanks for your attention and, of course, for your time. Happy Sunday!

1 Answer 1

0

OK. After querying people from the OpenSUSE community, we realize that the official repository of MongoDB doesn't have an AArch64 folder. For that reason I cannot list any package of mongodb even adding the repository, because it only has packages of a different OS architecture (86_64 vs AArch64).

However, the openSUSE community provides its own databases repository through this link: https://software.opensuse.org/download.html?project=server%3Adatabase&package=mongodb. The problem is that the latest version of MongoDB there is the 3.2.11. That's why I requested to the team to upgrade this version and upload the package of the 3.4 one.

I hope this answer to be helpful for somebody ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.