1

I have a Eaton 3S 700 UPS plugged to my Windows 7 Pro 64-bit computer by a USB cable, and I can't prevent the UPS from waking up the computer constantly. This happen both when the UPS is in battery mode and utility power mode while battery charging. The computer wake up automatically a few seconds or minutes after going to sleep mode.

According to the Windows Device Manager settings (Power Management tab), the UPS is not allowed to wake up the computer, only the network adapter and the mouse can :

C:\>powercfg -devicequery wake_armed
Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)
HID-compliant mouse

After some tests on USB devices wake ability settings, I found that the issue only occur when a least one USB device (mouse or keyboard) is allowed to wake the computer. When the network adapter (Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)) is the only allowed device, the computer stay in sleep mode and will only wake up from either the power button or a wake-on-lan magic packet. But this is just a workaround, I don't want to settle for it.

I grabbed some data just after the system has been awakened by the UPS :

C:\>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Device
    Instance Path: USB\ROOT_HUB20\4&28734d27&0
    Friendly Name:
    Description: USB Root Hub
    Manufacturer: (Standard USB Host Controller)

Event viewer :

The system has resumed from sleep.

Sleep Time: 2017-02-18T17:55:45.477601500Z
Wake Time: 2017-02-18T17:56:31.983600900Z

Wake Source: Device -USB Root Hub

I tried almost every tip from here and there (checked scheduled tasks, disabled wake timers, updated video drivers, updated BIOS, tried some control panel power management tweaks, enabled/disabled hibernation, enabled/disabled hybrid sleep) and got absolutely no results. Installing the official UPS management software (Eaton Power Protector) doesn't solve anything neither.

Then I took a look into the BIOS settings and I saw that ACPI 2.0 Support was disabled, so I enabled it and then did a fresh Windows installation on another hard drive (before installing the latest drivers and windows updates). Still no results.

In a last hope, I would like to know if anyone here could solve this issue. You can download very detailed information on my system configuration (Everest and dxdiag reports) here : https://drive.google.com/drive/folders/0B1ltKLthoSRbZTh4UGdULTFaUE0?usp=sharing

Next to that, I have some other related questions :

  • Is it the expected behavior (UPS wakes computer, no matter device manager settings) or could it rather come from a motherboard or UPS design flaw ?
  • Why does this issue only affects the UPS and not other USB devices ? Has it something to do with the fact that the UPS is self powered ?

Thanks

  • Are you using the Eaton software, "Personal Solution-Pac monitoring"? – Ale..chenski Feb 20 '17 at 3:38
  • No, I'm using Eaton Power Protector, which is suggested by the Eaton download center for the 3S product. – Vince Feb 20 '17 at 13:55
  • Did you try to disable "selective suspend" in your PC? – Ale..chenski Feb 20 '17 at 15:50
  • Yes, I tried with USB selective suspend setting set to Disabled and Enabled, with no effect on the issue. I also tried to unplug USB connectors on the mobo (front panel USB ports + SD card reader), no difference. – Vince Feb 20 '17 at 23:50
  • In device manager, how does the UPS appear (as USB device), what kind of device it is? USB speed, device class? USBview can be also helpful. – Ale..chenski Feb 21 '17 at 0:24
0

From the provided information the computer gets a wake-up (SMI) from root hub of EHCI controller. The wake-up event can be initiated by host itself (forced resume), or by remote wake-up from a connected device. Alternatively, if configured (usually via BIOS), the EHCI can wake up from external events as overcurrent (I assume this is not happening) or connect or disconnect event (which is also not likely). As you found, if the EHCI is blocked from waking up by disabling keyboard/mice (USB devices) as wake-up sources, the wake-up from UPS does not occur.

I am not sure about Windows general power policy, it is pretty much a screw-up, but it is entirely possible that proprietary devices as UPC are not managed, so they might not appear on the powercfg horizon. To diagnose the issue and determine who is the source of wake-up, either some USB-enabled Windows debug logs must be retrieved, or external USB protocol analyzer can be used. The analyzer (Teledyne-LeCroy, or Ellysis, or Beagle) should be able to record the sequence of suspend events, and the resume event. If the software suspends the port with UPS and means it to wake up, there should be specific control transactions enabling and arming UPS device for remote wake-up. If not, the wake-up (resume) happens internally.

The Eaton IPP software has some suspicious bullet in their feature list,

"Watchdog capability keeps kiosks with a PC or server running smoothly by automatically ..."

so it might be the root cause of the issue. There might be some configuration within the Eaton application to turn any watchdog service off.

  • If the UPS was not a power-managed device then the system would not support sleeping at all. The presence of any device that does not support power management causes the system to have two possible power states; On and off. – Jamie Hanrahan Feb 21 '17 at 1:31
  • @JamieHanrahan, every USB device supports power management in the form of SUSPEND, this is a mandatory mode.. – Ale..chenski Feb 21 '17 at 3:53
  • The USB devices, yes, but the function drivers .. – Jamie Hanrahan Feb 21 '17 at 3:59
  • @JamieHanrahan, yes, that's what I am saying - S/W screwup. Some (if not all) chipsets are quite buggy, and power management coherency is lacking (s*cks). I myself have X58 chipset, and can't use any sleep modes since then my PC would fail to resume, with very odd behavior of power and reset buttons. I gave up and use only ON and OFF mode. – Ale..chenski Feb 21 '17 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.