0

I am encountering a strange problem, which I don't know why happens.

I have a cheap IP camera and I am recording the stream to a file on my computer like this:

cvlc rtsp://ip/onvif1 --sout file/ts:video.mp4

When I run multiple processes like this to the same camera but different target files, the latest processes create HUGE file, like 1GB per second. After killing the bugged process, the video is corrupted and can't be opened.

This happened several times after killing current cvlc process and starting another one.

But the most strange thing is that once I run only 1 fresh VLC recording process and it created again such huge file.

Has anyone faced such glitches? Does anyone have an idea what might be the problem(cheap IP camera, Ubuntu 16.04)?

  • It's not clear what your problem is. Your current description sounds like it's creating a huge file regardless of whenever you run one or multiple processes. – Seth Feb 20 '17 at 8:45
  • @Seth I updated the question. It happened only once with only 1 running process. – CuriousGuy Feb 20 '17 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.