4

I recently upgraded my laptop to Windows 7 from XP. On XP, when nothing major was happening, the fan would be idle.

Now, on Windows 7, the computer speed is no different, and in some cases faster. But when I do nothing on the computer, the fan continues running. _However, watching the CPU usage shows that it is less than 5%.

I should also mention that I run Ubuntu 16.04 on my PC in dualboot and it idles the fan whenever nothing happens.

I've been able to use RMClock to reduce my CPU speed. This does reduce the fan volume significantly, but it still does not get as quiet as Ubuntu on the same machine.

What can I do to force Windows 7 to be quiet? I have no problem with further reducing the CPU performance as I'm not running any high-intensity games.

The air coming out of the machine is not very hot.

Specs:

  • Toshiba Satellite A70
  • 1.5 GB RAM
  • Windows 7 SP1
  • Pentium 4 538 (Prescott), with EIST (SpeedStep, previous generation) and HT
  • latest drivers (which are from XP, BTW)
  • ATI Radeon Mobility 9000
  • No antivirus running, but I have one installed
  • If you haven't already, check out this post for troubleshooting speedfan: superuser.com/questions/463650/speedfan-cannot-find-my-fan See if that can help. Otherwise, as far as windows without 3rd party software goes, energy settings is probably your best bet. Try this guide, but see if you can change it to a more power saving option: smallbusiness.chron.com/… If that helps. Good luck! – Christofer Weber Feb 20 '17 at 16:43
  • @Christofer This says that it should speed up the fan and keep it running. Not what I'm looking for. – user648246 Feb 20 '17 at 19:55
  • I know that guide was to speed up the fan, I mean it as a guide to find the power option. Obviously, you are supposed to set it to a power saving setting, rather than a higher one. – Christofer Weber Feb 20 '17 at 23:03
  • @ITSnuggles haven't measured the heat exactly. However, stock XP was able to not run the fan at all while stock 7 needs it at full speed by default. I was able to remedy some of the stock issues with 7 by using RMClock to keep the CPU at it's lowest frequency when idle. Windows 7 doesn't seem to do this on it's own. – user648246 Jan 9 '18 at 13:01
  • seems a driver compatibility issue. Disable automatic drivers update ( from device installation settings) then try to find a Chipset driver that's compatible with Windows 7 and install it. – iSR5 Jan 13 '18 at 0:50
3

I would update the bios first and than have a look in the bios for fan speed. You can find the latest bios here.

| improve this answer | |
  • The BIOS does not seem to have any mention of fan speed. However, it was a good suggestion, so I will still give you an upvote. – user648246 Jan 10 '18 at 11:51
2

It could be caused by Windows 7's Aero Glass user interface making the graphics processor (GPU) work harder than in Windows XP. Try disabling it and see if it makes a difference:

  • Right-click on the desktop
  • Choose Personalize
  • Scroll down through the themes to the section heading Basic and High Contrast Themes and choose something like Windows 7 Basic or Windows Classic
| improve this answer | |
  • I'm not using Windows 7 Aero as my graphics card doesn't support it. Thanks anyway! – user648246 Feb 20 '17 at 19:53
0
+50

Given the fact that above methods did not work at all for you, I would suggest this software to solve the issue.

This program shows the core temperatures of all the cores along-with the fan speeds. You can automate these settings or manually choose temperature limits when to switch on fans and how fast. The only problem is if this program is compatible with your hardware (it works fine on my system). You should give it a try. Also, if this does not work, there are many other such fan controlling software that enable you to even permanently switch off your fan (highly dangerous). For more details please visit this site.

| improve this answer | |
  • 1
    I tried SpeedFan, but it's not compatible with my hardware. – user648246 Jan 13 '18 at 15:23
  • Since this answer is the most useful solution to the problem (and probably works the best for others), I will award you the bounty for the attempt. – user648246 Jan 15 '18 at 23:14
  • thanks, I do hope you get a solution. And when you get please share it on this forum – M Shajeeh Mustafa Jan 17 '18 at 14:01
  • At the moment I'm using RMClock, but it's not a perfect solution. – user648246 Jan 17 '18 at 15:17
0

First, check the BIOS for fan settings. You might find what you need.

But consider that it could be a loose or broken wire connecting your fan. Hardware problems are common, lol.

| improve this answer | |
  • I don't see how upgrading from Windows XP to Windows 7 could have changed the BIOS settings. – Blackwood Jan 15 '18 at 22:38
  • The fan works quite well on Linux as I mentioned already. – user648246 Jan 15 '18 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy