3

I have a weird DNS issue in my PC - Windows 8.1 using Ethernet connection. The DNS server stop to response after ~30 min, When in other devices everything works. When I ping direct IP, everything works. When I ping host name, I received a timeout. Iv'e tried to clear DNS cache, reset winsock, set static DNS servers(8.8.8.8), disable IPv6(from regedit), restart "DNS client" and "Server" services, update drivers of my network adapter, but the issue haven't resolved.

When I run "nslookup" I received timeout and after few minutes I see: "Default Server: UnKnown".

When I run ipcofnig /all, everything look ok.

I run whireshark on my network and I can see the DNS server returns A response, but the next TCP request isn't continue.

When I reboot my computer the issue fixed, but after ~30 minutes it happen again.

Some information:

IPCONFIG /all:

C:\WINDOWS\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ******
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : Home

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : Home
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : *********
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 2017 17:47:29
   Lease Expires . . . . . . . . . . :  2017 17:47:29
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

NSlookup:

C:\WINDOWS\system32>nslookup
DNS request timed out.
    timeout was 2 seconds.
Default Server:  UnKnown
Address:  8.8.8.8

>

tracert:

C:\WINDOWS\system32>tracert 8.8.8.8

Tracing route to google-public-dns-a.google.com [8.8.8.8]
over a maximum of 30 hops:

  1     *        *        *     Request timed out.
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7     *        *        *     Request timed out.
  8     *        *        *     Request timed out.
  9     *        *        *     Request timed out.
 10     *        *        *     Request timed out.
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15     *        *        *     Request timed out.
 16     *        *        *     Request timed out.
 17    69 ms    69 ms    69 ms  google-public-dns-a.google.com [8.8.8.8]

Trace complete.

WireShark capture:

enter image description here

0

Your firewall is likely blocking responses from port 53. Try allowing this and seeing if the lookups complete.

  • My firewall is disable. – user2970756 Feb 20 '17 at 18:51
  • Check for a firewall further upstream (such as router) as it looks like it's being blocked somewhere. Possibly UDP being blocked. – Scott-Mc Feb 20 '17 at 21:56
  • There is not a firewall on the router. – user2970756 Feb 20 '17 at 22:02
  • What you are describing and the outputs definitely look like it's being blocked by a firewall / application. Given the fact it works when you reboot it would indicate it's some sort of firewall/app that gets started which leads to the blocking. When it's occurring maybe go through the processes and try stop them until you find which one is causing it (but firewall/antiviruses are prime suspects). – Scott-Mc Feb 20 '17 at 22:09
  • I will try it, but I think it happens due to a firewall, It supposed to happened when the machine start, and not after ~30 min'. – user2970756 Feb 21 '17 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.