34

I have a desktop computer and a laptop computer on the same WiFi network. The desktop can connect to the VPN, but the laptop cannot.

VPN Connection specs:

  • Type: PPTP
  • Sign-in: User name and password
  • Certificate stored locally in Trusted Root Certification Authorities
  • Security > Authentication: "Microsoft: Secured password (EAP-MSCHAP v2) (encrypted)"

Desktop specs:

  • Windows 10 Home (64-bit)
  • WiFi connection

Laptop specs:

  • Windows 10 Home (64-bit)
  • WiFi connection

What I've tried:

  • Verifying the settings listed above match between laptop and desktop
  • Connecting laptop directly to router via Ethernet
  • Exporting my firewall settings from desktop and importing them to laptop to make sure they match
  • Windows "Network Reset" in Settings (app) > Network & Internet > Status
4
  • Have you tried connecting when you are using an Ethernet connection instead of a wireless one? That is Step 1 – InterLinked Feb 21 '17 at 21:49
  • 1
    Yes. I have that in the "What I've tried" list – Matt Feb 22 '17 at 17:32
  • If anyones reading this - and none of the answers worked: Add registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent with value = 2. Restart PC - worked for me – Daniel Cooke Jun 23 '19 at 18:03
  • Make sure that VPN is really not working, because the tray menu continues showing "Connecting" after it's actually connected and working. – bdrajer Feb 20 '20 at 9:57
46
  1. Open Device Manager
  2. Find Network Adapters
  3. Uninstall WAN Miniport (IP), WAN Miniport(IPv6) and WAN Miniport (PPTP).
  4. Click Action > Scan for hardware changes
  5. The adapters you just uninstalled should come back
  6. Try connecting again
11
  • 3
    Didn't Work for me. – Nirav Madariya Apr 14 '17 at 17:26
  • 2
    It did for me! We must have had different root causes to the same problem – Matt Apr 19 '17 at 14:08
  • still it's not working, I can't connect to any VPN. – Nirav Madariya Apr 19 '17 at 14:17
  • 1
    This solved the problem I was having with some VPNs on Windows 10. (Another VPN was still working OK.) – Leo Davidson May 25 '17 at 10:24
  • 6
    I have no idea why this fixed the problem I was encountering, but it did, so thanks! – reirab Oct 28 '17 at 22:48
8

I have exactly the same issue, and was unable to find a solution for ages.

The issue for me is the "Xbox Live Networking Service". Even on a clean Windows 10 install, the VPN would work once or twice and then get stuck again.

I can replicate the issue 100% by starting the "Xbox Live Networking Service", when it is started, I can't access any VPN, when it is stopped VPN works perfectly.

Steps to resolve: 1. Open Services (services.msc) 2. Scroll down to "Xbox Live Networking Service" 3. If the service is running, highlight it and click stop 4. VPN should now work, no need to restart etc

I have reported this to Microsoft recently. It is reproducible even on clean installs.

2
  • 1
    Same issue for me. – Jeremy Frey Nov 12 '19 at 15:14
  • Still happening in Win10 as of today - thanks for the fix – tr00st Dec 22 '19 at 23:20
5

First - make sure you're not on Public - check your firewall settings

Next

  • Go to Network and Sharing in Control Panel
  • Click on Change Adapter Settings
  • Right click on VPN
  • Click Properties
  • Click on Networking Tab
  • Uncheck Internet Protocol Version 6 (TCP/IPv6)

Click on Security Tab

  • Choose - Allow these protocols
  • Check the box for - Challenge Handshake Authentication Protocol (CHAP)
  • Check (if not already checked) Microsoft CHAP Version 2 (MS-CHAP V2)
  • click ok - save if prompted

Next right click on Wi-Fi

  • Choose Properties
  • Uncheck Internet Protocol Version 6 (TCP/IPv6)
  • Click ok

Do the same steps for your Ethernet as above for Wi-Fi

That should fix it; if not then you need to do 1 more step:

Go to your Network Settings

  • Click on VPN
  • Choose Advanced Options
  • Scroll down to Automatic configuration
  • Turn on the Automatically detect settings or choose Automatically detect settings
  • Click Save

Now go connect your VPN.

If it shows it is still trying to disconnect you either have to shutdown completely your system then power back up or you may need to delete that VPN connection and setup a new one with the above settings.

As always contact your IT dept. to assist.

2
  • 2
    this all sounds very voodooish to me... Why should I change my networking profile from public to anything else - normally I am in a public network when I want to connect to VPN? Also changing the settings of your WIFI Adapter definitely has nothing to do with VPN! – user1859022 May 22 '18 at 11:39
  • Worked for me. I had issues with just one provider and it always worked when used cellular network...thanks. – SunMan Aug 30 '19 at 5:36
4

In my case, the solution was as simple as going to Settings -> Network & Internet -> VPN and connecting from there.

For some reason, this works, but connecting from the quick menu in the task bar doesn't.

Source: https://blog.techinline.com/2018/06/01/vpn-stuck-on-connecting-windows-10/

2
  • I suspect that the answer that had you reinstall a bunch of WAN Miniport drivers was part of my problem, but this is what finally resolved it! – Mike Caron Jan 13 '20 at 20:45
  • 1
    that's worked for me – Ami Hollander Oct 3 '20 at 13:04
1

I had a similar issue, and the solution was not intuitive thanks to the separation of various settings in Windows 10. Using the "Settings" app did not let me change the options for the VPN.

However, the following worked:

  1. Open the Control Panel (the traditional one)
  2. Go to "Internet Options"
  3. Go to the "Connections" tab
  4. Select your VPN in the list and click "Settings"
  5. Click "Properties"
  6. Go to the "Security" tab
  7. Select "Allow these protocols" and check the MS-CHAP v2 option
0

After having tried all the "solutions" to this problem as found on Internet, I finally found one that worked. Can´t remember the the site where I found it, but for me it works every time. I use Windows 10 professional.

Try this:

Kill any active browsers

Go to Services (C:\Windows\System32\services.msc)

Find DHCP Client

Restart it.

Connect to your VPN

Check your new IP address via your browser

It works for me!!

2
  • 3
    Thanks, but it did not work for me. – Matt Feb 22 '17 at 19:22
  • I think you're being banned from the VPN server over and over so that's why you can't access until you get a new IP (restarting the DHCP service) – campsjos Feb 22 '19 at 13:23
0

I've had similar issues with this that required changing the VPN type from "Automatic" to "PPTP" or "SSTP" depending on the server configuration. It definitely started after recent Windows 10 updates. Hope this helps

1
  • Your answer is good for a comment, please Edit your answer with more information – yass Jun 28 '17 at 22:04
0

In vpn adapter properties, Click on configure then advanced and then set media status to always connected then reset the adapter.works for me but i have to reset every time.

-1

Hi i had the same problem and i did this and after that i opened my vpn app and everythings work! Go to windows defender firewall and click on turn of or on the firewall and turn of your firewall for a while and do your job than after your job turn on the firewall again to protect your pc tottaly works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.