This is a problem that occurs often (but not always) on my Windows 10 laptop... I turn it on and connect to a wi-fi network; and I get the icon that means "connected, but no internet". When this happens, I go to the "Network connections" and look at the Wi-fi properties. Under TCP/IPv4, I find that it is set to "Obtain IP address automatically"; but the DNS server address has reverted to an old (and incorrect) DNS address that I had once entered manually. I click the box that says "Obtain DNS server address automatically", click OK, and then all is fine -- until this happens again.

How can I get my system to forget that old, wrong DNS address once and for all?


To clear your DNS cache:

  1. On your keyboard, press Win+X to open the WinX Menu.
  2. Right-click Command Prompt and select Run as Administrator.
  3. Run the following command:

    ipconfig /flushdns

If the command succeeds, the system returns the following message:

Windows IP configuration successfully flushed the DNS Resolver Cache.
| improve this answer | |
  • @naarzan This will purge the DNS cache but not change the configured DNS server – Benjamin Hastings Feb 20 '17 at 22:23
  • 1
    Before you setup your DNS as Static or Dynamic from your PC run this command, to clear the "cash" if something stuck it will solve that, check this documentation technet.microsoft.com/en-us/library/cc794721(v=ws.10).aspx – Narzan Q. Feb 20 '17 at 22:26
  • 1
    Thanks. I did this (@benjamin hastings: after I had reconfigured TCP/IP so that it works correctly) and received the message you indicated. Since this solution looks very promising, I went ahead and accepted this answer. You can be sure I will angrily uncheck it if the problem recurs :-) in the future! – Russ Lenth Feb 20 '17 at 22:32

I had this issue with an Windows 8 computer that would not let go of some old TCP/IP settings that I had set once even though it was already configured for DHCP.

I searched the registry for that IP address and deleted the value and rebooted

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.