0

A few others had the same problem; no hardrive is found by install:

This is my hardware:

I tried:

I ordered a Samsung SM951 (AHCI) M.2 (it is on the approved PX1 list and uses the AHCI driver) - it will be here on the 27th.

  • If your motherboard doesn't have a M.2 connector, is there a reason, your using a M.2 SSD? It is very likely your problems are because of the adapter. "I did not try the Intel Rapid Storage Technology since it is not offered for Win10" - Yeah, it actually is. – Ramhound Feb 21 '17 at 19:54
  • 1
    Intel® Rapid Storage Technology (Intel® RST) RAID Driver. Of course unless you want a RAID this driver isn't required. – Ramhound Feb 21 '17 at 19:56
  • Please clarify: M.2 Samsung x400 or Sandisk x400 M.2 – Ramhound Feb 21 '17 at 20:03
  • If you have the Samsung device, you can try using the Samsung NVMe Driver. If that doesn't work try the IRST drivers as I previously provided. – Ramhound Feb 21 '17 at 20:04
  • I don't understand your last comment. I linked you to Windows 10 IRST compatible drivers. – Ramhound Feb 21 '17 at 20:15
1

M.2 is a form factor, not an interface: "Buses exposed through the M.2 connector are PCI Express 3.0, Serial ATA (SATA) 3.0 and USB 3.0" (link)

It appears (from Newegg and Sandisk) that the Sandisk x400 uses the SATA interface.

The Samsung evo 960 on the "approved drives" list on the adapter card site is an M.2 device that uses the PCIe interface. I did not run down the full list to check them all.

One side-track link I followed to Dell support states: "Note : Not all SSDs with an M.2 Interface are PCIe SSDs." (link)

So I strongly suspect that you simply have a compatibility problem between the card which is for PCIe M.2 devices and an SATA M.2 SSD device.

  • I ordered a Samsung evo 960 and a Samsung SM951 (AHCI); between these three cards hopefully one will work. – forest.peterson Feb 21 '17 at 23:29
  • ^ I ended up buying three motherboards (one has an M.2 socket) and three M.2 drives (mix of SATA and PCIe and of NVMe and AHCI) plus a PCIe adapter. I had one that works (board with M.2 socket and I don't recall which M.2 drive), but, the CPU was not supported. I found another solution (PCIe adapter) that would have worked with some BIOS mods (I chickened out - at that point I grabbed my backup plan, dual SATA3 SSDs in RAID0). – forest.peterson Mar 25 '17 at 18:16
  • ^^ Nice explanation here computershopper.com/feature/… key advice "verify with the board maker that an M.2 SSD of the bus type you are considering will be bootable" – forest.peterson Mar 25 '17 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.