I have a 16GB SAMSUNG EVO microSD card that I was using on RaspberryPi 2 with NOOBS installed on it. I tried to format it in every way possible:

  • from Windows 10 with SDFormatter;
  • from Windows 10 with partition manager;
  • from Windows 10 I tried to overwrite it with Win32 Disk Imager;
  • from Linux (elementaryOS) using GParted (I tried to delete every partition but I get an error that says that is impossible to inform kernel and I also tried to create a new partition table, but everything remains untouched);
  • from Linux (elementaryOS) terminal using the command sudo dd if=/dev/zero of=/dev/mmcblk0.

The thing is that from the NOOBS menu, I managed to delete operating systems on the SD adding only a data partition, but when I put it back on PC I cannot do nothing as before.

The other strange thing is that with Win32 Disk Imager I can restore successfully the backup of the SD that I made before trying to format it.

If it matters on the SD I had installed OSMC and Raspbian and I extended the file systems to occupy the unused space from Raspbian options.

I don't know what else to try... any suggestions?

  • 1
    Two days ago a Samsung 8GB microSD card became read-only. Nothing changes its contents, including dd comands (like you did) on two different SBCs with microSD sockets (i.e. no adapter needed). There was a web page at the SD Association (that I cannot find anymore) that mentioned that this is a known failure mode. Anyway I downloaded some "simplified specs", and was going to poke around the card's interface later.
    – sawdust
    Feb 21, 2017 at 22:37

1 Answer 1


Windows Disk Management can't work with every possible scenario, but I find that diskpart is quite useful where you want to completely erase all partitions on cards like this. This guide to using the diskpart 'Clean' command would be your best bet on Windows in my opinion: https://www.sevenforums.com/tutorials/52129-disk-clean-clean-all-diskpart-command.html

Otherwise, if the card is faulty you may need to replace it.

  • It didn't work, I think that the card it's just defective. Thank you.
    – ajeje93
    Feb 22, 2017 at 14:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .