I have purchased an Edimax 7318USg and tested it on a Windows machine (works). The installation process for the software for this adapter runs smoothly. However, OS X simply does not recognize new network adapters. When you go to System Preferences/Network, a new network adapter should be present/there should be an alert. This is not the case.

Why might this be? Is there a setting I may reset to force the operating system to recognize this?




I see you commented about still not having any luck?

Is there an uninstall app? Sometimes they do not play nice if you have tried multiple installs. I had this happen with a rosewill wireless usb adapter. Once I uninstalled everything I tried before, it then worked with the newest drivers installed fresh. Try uninstalling if you can... and starting from scratch.

Hopefuly there is an uninstall to make this easy.

EDIT: Also, make sure the device is not plugged in from the start.

  1. Uninstall previous attempts
  2. Restart
  3. Install Drivers
  4. Restart
  5. Now plug in device and see what happens

Let us know if that works?

EDIT 2: Also, do you have other 3rd party wireless cards installed or have installed in the past? Out of curiosity, what type of mac are you trying to install this on?

You can check for the device existance in the system profiler under the USB bus and see if it is there. It would be under the USB category-->usb bus-->some device name. There might be many usb bus's depending if any usb cards or hubs are connected. Are you connecting this straight to the mac or through a hub possibly?

The company mentions 10.4.x and 10.5.x in the compatibility section of the manual. So they claim to support the exact configuration you are using. This might be one to call in to the company if worse comes to worst.

  • my apologies for the double posting from before. the article was well buried at that point and there was no way i'd get any new help. i have tried completing uninstalling it and starting over. no luck – Chris Jul 17 '09 at 0:20
  • Unfortunately, this is a no go. I wish osx played a sound when you plugged a device into the usb port (like windows does) so i at least knew it acknowledged its existence. – Chris Jul 17 '09 at 0:39
  • Thanks again. This is my first 3rd party wireless card on this system. This is an early 2009 macbook, running leopard. I've checked the system profiler, and there is indeed one usb hub with "802.11 bg WLAN". So the system is aware of it in some form. – Chris Jul 17 '09 at 0:50
  • Sorry, forgot to answer your last question. Directly to the mac. Nothing in between. – Chris Jul 17 '09 at 0:52
  • That's why I'm so stumped. I was emailing back and forth with a customer support agent (to no avail). They were also stumped. I ordered this off of newegg, so returning it will cost me money in the long run, or else I would have by now. Thanks once again. I'm astounded that you've put this much effort into helping me so far :) – Chris Jul 17 '09 at 0:55

People do seem to have problems with this adapter... a quick google turned up this article on InsanelyMac... it seems a full recycling of the power to the machine post-install helped one person. Good luck.

  • what do you mean by full recycling of the power? a simple reboot? I did see this article earlier and was unable to get it going after shutting down, unplugging and replugging the adapter, then booting back up. Thank you for your help, however – Chris Jul 17 '09 at 0:22
  • Sorry, yes, that's exactly what I meant, the slightly complex reboot with the unplugging and replugging the adapter. Even more sorry that it didn't work! Good luck getting it sorted... – avstrallen Jul 17 '09 at 10:37
  • Thanks for the attempt :) I'm toying with the idea of a clean reformatting to test this out.. – Chris Jul 17 '09 at 12:58

This was an issue with the driver for this device for this brand of macbook. Customer service have now informed me of a new driver, which is working. Thanks to all that assisted me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.