1

I have tried to uninstall Visual Studio 2015 via Programs and Features but the uninstaller is not there. So, I started searching around and I found this in one blog somewhere:

  • First go to C:\ProgramData\Package Cache\{37e19555-e88d-4aed-9d42-82d0784d2b79}
  • run vs_enterprise.exe /uninstall /force via a command prompt

But the {37e19555-e88d-4aed-9d42-82d0784d2b79} folder does not exist and I can't seem to find vs_enterprise.exe any where in my computer.

I am not sure what has happened to Visual Studio 2015, and why I can't find the vs_enterprise.exe, but VS opens OK.

Update:

I have Wwindows Server 2012 R2 and I have tried to do a repair, but as I said above, I could not see the uninstall option in Programs and Features.

So, I run the installer from the ISO image, and to my surprise it did not ask me if I wanted to uninstall visual studio 2015, but was asking to install it.

I thought perhaps it is a good idea to install it again and that might overwrite the existing installation. But what it did was a new installation above the current one, because when I ran the uninstaller the previous installation was there. Very strange.

Any idea how to uninstall it?

  • What folders reside under C:\ProgramData\Package Cache\ ? – Alex Feb 22 '17 at 9:31
  • Try to use a 3rd party software like Revo uninstaller. – Scorpion99 Feb 22 '17 at 10:50
3

Try to use this VS uninstaller which you can find in GitHub https://github.com/Microsoft/VisualStudioUninstaller/releases.

Usage:
0. Extract TotalUninstaller.zip
1.Open an administrator command prompt.
2.Execute Setup.ForcedUninstall.exe
3.Type 'Y' to uninstall.

Have a look at this as well: https://msdn.microsoft.com/en-us/library/mt720585.aspx

| improve this answer | |
  • the tool helped a lot. I was able to uninstall it. Thank you for your help guys. All of you. – Burre Ifort Feb 22 '17 at 9:40
0

Did you try to repair VS2015 first as described on the MS support site? Also you didn't mention what OS you are you using (the repair option works only on Win 7 and earlier) so I am assuming you are using Windows 7:

"In the Programs and Features window, right-click Visual Studio, select Change, and then click Repair to start the repair process."

From MS support site - Multiple feature installation errors in Windows 7

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.