8

I have recently installed VirtualBox on my Mac and am trying to install Windows 7 on it. I have done this a couple times in the past alas it has not been for several years.

I was originally getting an error when booting my VB machine (although I forget what the error message was) which meant that I had to change the boot order so that Optical was at the top:

boot order

Now however, I am getting the following error when booting:

Could not read from the boot medium! System halted

I had a look on YouTube and believe that I need to edit the following settings:

enter image description here

However I'm not sure what settings to go for in terms of my machine.

1
  • Did you check, if your VB is allowed to use the optical drive. You can change this over the menu of the virtual machine. – IQV Feb 22 '17 at 11:31
6

Change SATA controller to IDE controller and right click on the IDE controller to get the option: add "optical drive" to pop up, select it & move to thw right to select the iso image.

2

Today I installed Kubuntu20.10 on an external usb disk (encrypted, lvm) and also got the same error message.

For me changing the Bios settings to EFI standard solved the problem.

enter image description here

1

For me the solution was to switch from SATA controller to IDE using the same vdi disk image. I tried all settings I could imagine after doing the usual Google search but nothing got rid of the boot error.

1
  • Can you elaborate on this? – fixer1234 Apr 23 '17 at 5:07
-1

create the virtual machine using another computer and export it in ovf format then import to your computer. this works fine

1
  • Can you explain why this would make a difference? – Scott Oct 24 '20 at 14:39
-1

I had the same issue. Try changing the boot order to hard disk instead of optical.

Click on this to see the picture

1
  • The OP is trying to install an operating system on his VM by booting from an optical disk.  How does your answer make any sense in that context? – Scott Jan 26 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.