Here is the error message:

System Restore did not complete successfully. Your computer's system files and settings were not changed.


System Restore failed while restoring the directory from the restore point.
Source: AppxStaging
Destination: %ProgramFiles%\WindowsApps
An unspecified error occurred during System Restore. (0x80070091)

Screenshot of error message

What I've tried so far:

  • chkdsk /f /r C: (didn't work)
  • tried running in safe mode the system restore (didn't work)
  • tried with another system restore point (didn't work)
  • Do you by chance have a start menu replacement installed?
    – Ramhound
    Feb 23, 2017 at 1:41

2 Answers 2


This happened to me after I updated my Lenovo's drivers and had issues with driver power states. I was able to perform a restore by doing the following:

  1. Boot into command line mode (search Advanced Startup in windows settings)
  2. C:
  3. cd C:\Program Files
  4. attrib WindowsApps -h this removed the hidden attribute
  5. rename WindowsApps WindowsApps-renamed
  6. exit
  7. restore the system to the desired restore point
  8. reboot normally or continue to windows

When the restore is complete, a previous version of WindowsApps will have been restored.

To then go back and delete WindowsApps-renamed:

  1. win+x
  2. a to open an Administrator Command Prompt
  3. cd C:\Program Files
  4. takeown /f WindowsApps-renamed
  5. rmdir WindowsApps-renamed /S
  • I got the exact same issue but on another drive D:\WindowsApps I did the same steps but I got the same error and can't restore. Any ideas?
    – Enrico
    Mar 17, 2021 at 9:39
  • @Enrico Is D: a network drive? Are system restore points enabled on that drive. Does Get-ComputerRestorePoint list any restore points?
    – Jon
    Mar 17, 2021 at 17:35

This is a known issue. delete or rename folder WindowsApps then restart system, after this, restore function can be cover. follow this link step by step to fix this issue.

Windows 10 Version 1607: System restore error 0x80070091 [Fix] http://borncity.com/win/2017/02/22/windows10-version-1607-system-restore-error-0x80070091/

Here is a thread discussing in Microsoft forum for your reference.

System Restore failed - Source: AppxStaging Error - (0x80070091) https://social.technet.microsoft.com/Forums/windows/en-US/93a0d2a2-d9f1-4b57-97b9-0ca30de656aa/system-restore-failed-source-appxstaging-error-0x80070091?forum=win10itproapps

  • Your post needs to be expanded. A good answer includes specific instructions (not just links to them) and an explanation as to how or why the answer addresses the OPs question. Please edit your post to adequately address both of these elements. Apr 26, 2017 at 11:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.