0

I am trying to mount my university's windows file server under linux. When I run sudo mount -v -t cifs -o ro,username=****@***.ca,password=*** //server.cm.uni.ca/ /media/marcel/server, I get the following output:

mount.cifs kernel mount options: ip=***.103.8.48,unc=\\server.cm.uni.ca\,user=***,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I tried with and without the ro flag. Since it is a university server, the access is pretty limited. I only have read access. Is there anything else I can try before getting help from someone on campus?

uname -a:

Linux Hermes 4.9.11-1-ARCH #1 SMP PREEMPT Sun Feb 19 13:45:52 UTC 2017 x86_64 GNU/Linux

I can access the server just fine under windows with the same credentials.

Edit: I also tried mounting just one share: //server.cm.uni.ca/share/.

  • Can you use sudo mount on other Windows/Samba network file systems? Is /media/marcel/server a directory with full access for root? Does /media/marcel also have full root access? It looks more like a Linux configuration problem than anything to do with network permissions. – AFH Feb 24 '17 at 13:38
  • Without sudo I get mount: only root can use "--options" option. /media, and /media/marcel. All subfolders are owned by root and are 755. marcel is in wheel. – Marcel Feb 24 '17 at 13:42
  • That's as expected: mount has only display options unless run as root. What about /media/marcel/server? – AFH Feb 24 '17 at 13:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.