21

When I try to run Wget with the following options:

E:\Program Files\GnuWin32\bin>wget -p --html-extension --convert-links --no-check-certificate https://minecraft.net/en-us/
SYSTEM_WGETRC = c:/progra~1/wget/etc/wgetrc
syswgetrc = E:\Program Files\GnuWin32/etc/wgetrc
--2017-02-24 10:38:01--  https://minecraft.net/en-us/
Resolving minecraft.net... 52.84.24.33, 52.84.24.150, 52.84.24.230, ...
Connecting to minecraft.net|52.84.24.33|:443... connected.
OpenSSL: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
Unable to establish SSL connection.

I get the error: Unable to establish SSL connection. The website that I am trying to download is safe.

I have also tried to change the protocol to SSLv3, but it still is not working.

Can someone tell me why it is doing this and how to get around it?

  • What type fo connnection is this server expecting? It migh be configured to support (SSLv1, SSLv3, SSLv3, TLS 1.0, TLS 1.1, TLS 1.2) or any combination of those possible choices. Does a connection to this website work within a browser, on the same PC and connection, your attempting to connect to it with wget? – Ramhound Feb 24 '17 at 19:10
  • I can access this website on my computer normally using Chrome with no problems. – William V. Feb 25 '17 at 1:01
  • I look's like it may be using the SSLv3 connection as it states the following in the error: routines:SSL23_GET_SERVER_HELLO:sslv3. – William V. Feb 25 '17 at 1:02
  • That is what, wget is attempting to use, but the server is rejecting that connection because SSLv3 isn't secure. – Ramhound Feb 25 '17 at 1:48
  • According to other answers below, it looks like the protocol is TLSv1.0 – William V. Feb 25 '17 at 1:50
14

As SSL Labs shows, only TLSv1.0 and above are supported by minecraft.net. You can't use SSLv3 with it. It's likely that your version of wget doesn't support this (possibly due to being too old). Try upgrading it.

| improve this answer | |
15

You can find a newer version here: Windows binaries of GNU Wget

It works fine, I had the same problem.

| improve this answer | |
  • The exact file link is here: eternallybored.org/misc/wget/releases/wget-1.19.1-win32.zip – William V. Aug 18 '17 at 19:23
  • 1
    Years later, version 1.20.3 was available... but it had problems. I had to run this to get a working version (under Windows): choco install wget --version 1.20 – MarkHu Apr 17 '19 at 21:27
  • I have the problem that all 64bit Versions of this wget there always crush after some seconds of downloading a file over https – Radon8472 Nov 21 '19 at 14:56
  • I had wget 1.11.x - moving up to 1.20.3 resolved this for me as well. Thanks. – Christopher D. Emerson Dec 17 '19 at 14:02
2

I downloaded the 32-bit .exe file. It works.

wget.exe np -r -nH -L --cut-dirs=2 https://coast.noaa.gov/htdata/lidar1_z/geoid12a/data/3654/20090316_249102.laz
| improve this answer | |
1

You may want to add --secure-protocol=TLSv1 option.

Check also if installed OpenSSL supporting TLS by running:

openssl s_client -connect minecraft.net:443 -tls1
| improve this answer | |
  • --secure-protocol+TLSv1 Gave me the same error that I got before. – William V. Mar 17 '17 at 20:59
  • @WilliamV. I just run the same wget ... string by copy/pasting it from your question without changes on debian 8 jessie and it works without any error. Since you using some Window's port of wget, it looks like linked OpenSSL lib is outdated. Try to setup virtual machine with bare(non gui) debian and it should work. Another option, - use cygwin, it always comes with most recent versions of all programs. I just check the same wget... from cygwin, and it worked too. – Alex Mar 18 '17 at 5:01
  • I can't install cygwin. Is it possible that I could try this on Xubuntu with Wget? I have a Linux machine that is running Xubuntu currently. – William V. Mar 29 '17 at 1:05
1

Had a similar error, but in my case only “Unable to establish SSL connection.” was shown without explanation. I have used a WinWget, which included a wget compiled without SSL support. Solved by downloading full version from https://eternallybored.org/misc/wget/

| improve this answer | |
0

I had this problem and using a newer wget as mentioned in other answers solved it. However I'm not into installing binaries from random sites, if you're on Windows as the OP is and have WSL installed with Ubuntu then you can open a bash shell and have the latest ubuntu wget. If wget not installed:

sudo apt install wget

You can easily get to your windows stuff via cd /mnt/c (or d or whichever drive)

| improve this answer | |
0

adding to the accepted answer: if you're on windows and don't find or don't trust a reasonably new wget, try curl instead. As mentioned here it may already be included in Windows 10.

| improve this answer | |
  • You might try adding your information as a comment to the accepted answer. – William V. Feb 1 at 2:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.