2

I am trying to install a piece of software from a Application Manifest. I get an error of the following:

Application cannot be started. Contact the application vendor.

After contacting the vendor, the answer is that there is a corrupt file on my machine (Windows 10).

I also looked at detailed information in the error message.

Summary:

Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of C:\Users\.... resulted in exception. Following failure messages were detected:
        + Deployment and application do not have matching security zones.

Detail:

Following errors were detected during this operation.
    * [2/25/2017 12:12:07 AM] System.Deployment.Application.InvalidDeploymentException (Zone)
        - Deployment and application do not have matching security zones.
        - Source: System.Deployment
        - Stack trace:
            at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath)
            at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
            at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
            at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
            at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

When researching the issue, there are many application developers on stackoverflow (and other sites) working to resolve corrupted files. But none of them were from the end user standpoint.

My question is: How do I figure out which file is corrupt? And how do I fix that file?

  • If the vendor says a file is corrupt, he or she should be able to tell you which one is corrupt. If they cannot, they are guessing and did not provide you with any useful information. – Dawn Benton Feb 25 '17 at 6:41
1

This is wrongly tagged as a Windows 10 issue, when it is actually an issue that applies to all versions of Windows.

Deployment and application do not have matching security zones means there is a mis-match between the security settings in the deployment environment - i.e. your Windows O/S, and those embedded in the .exe application you are trying to run.

Detecting such a mis-match is a basic security feature, common to all versions of Windows (going all the way back to Windows 98). If the O/S thinks the program being run is a security risk, it isn't going to run it.

The answer to the question being asked, of course, is that there is no solution.

This error, in many (though not all) of its various manifestations, informs the user to contact the application vendor: this is because (and is an admission of the fact that) this error has no user solutions. It can only be resolved by the developer.

If you're getting the error, it means Windows doesn't think the developer has signed the manifests. The developer has likely failed, in the Signing tab, to check/tick the check box; and/or has failed to select a valid security certificate; and/or has failed to publish the software as Full Trust (but only as partial trust). (There are other possibilities too, but those are the obvious ones.) Such errors are developer errors, so can't be fixed by the end-user.

  • This accepted answer does not seem to be always correct, as at least for a few people the solution from the other answer worked: superuser.com/a/1303057/11875. – Sergii Volchkov Feb 20 at 8:22
  • The other answer implies that the .exe application file is valid, or is not, depending on which browser you download it with. That cannot be so, because doing that makes no change in the .exe file. The problem I discuss is about the O/S rejecting the .exe file, but the choice of which browser to use for the download is irrelevent to that issue. What is probably occuring in the other answer is that Firefox has its (optional) security settings mis-set, so that Firefox is mistaking the .exe file for a security risk, so refuses to download it. That is a very different problem. – Ed999 Feb 22 at 20:16
  • 1
    the other answer offered a solution that did work for me personally, however now that you mention it, the sequence is indeed somewhat different between the browsers. In my case, there's a Miscrosoft Web application, which provides a certain link on the menu. In Firefox and Chrome, clicking that link results in downloading of an .application file - the file which then refuses to launch same exception as in OP's question. Clicking the same link in IE. however, does not result in a download, but rather immediate launch of the app, possibly with different security settings. – Sergii Volchkov Feb 22 at 20:52
  • 1
    Sounds like the security settings in your Firefox browser are doing a good job - I was wrong to describe them as possibly mis-set, if what they are doing is preventing the .exe file from running. A browser must always only download an executable file! It should never run/launch the file, because that represents a major security risk. The .exe file would run before you've had a chance to check it with an anti-virus program to find out whether it's safe or whether it's infected with a virus! Internet Explorer, as always, is a bad security risk - don't use it! – Ed999 Feb 24 at 9:11
7

In my case (Microsoft Office 365 eDiscovery Export Tool), the error appeared when downloading the file with Firefox. I switched to Internet Explorer to download and start the .application file and then the installation succeeded.

  • 1
    This was my issue too. – Linuxx Nov 21 '18 at 19:15
  • Same with a Telerik demo installer: works in IE but neither Firefox nor Chrome. Thanks. – Baptiste Candellier Dec 10 '18 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.