1

Here is the case:

I installed Sublime Text 3 on my Windows 8.1 . When I try to save my user preferences and/or keybindings, it throws following error:

Unable to save C:\Users\w\AppData\Roaming\Sublime Text 3\Packages\User\Default (Windows).sublime-keymap. Error: The system cannot find path specified.

I do know what causes the error. Mentioned path specified do not exist indeed, as my system username is w$courge, which contains $ dollar character and Windows can't wrap it's head around it. The path is:

  • C:\Users\w$courge\AppData\Roaming\Sublime Text 3\Packages\User\Default (Windows).sublime-keymap*

I studied the "How to rename user folder in Windows 8?" thread to get general idea of doing it the other way — adjusting Windows instead of adjusting ST3, but I do not want to do that.

So, is it possible to change the location of preferences/bindings files, either during fresh installation or in an already installed ST3? Or do I have to help my Windows with the dollar sign?

  • Windows can perfectly wrap its head around $ in the path; I have numerous folders and software development experience to prove that. It looks like a Sublime Text bug. Why don't you contact their support team and file a bug report? – user477799 Feb 26 '17 at 7:59
2

I would recommend changing your username to not include special characters. This will be an issue in the future, whether it's with Sublime or something else.

But if you want, you can try installing the portable version of sublime text. This would enable you to avoid saving your preferences to your Windows user path.

I haven't seen anything about changing the location of the preferences file's location in a normal installation. Someone else may know how to do it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.