2

I know this question has been asked several times. But all answers on those questions haven't worked for me.

I'm trying to install a new virtual machine using VirtualBox 5.1.4 (VirtualBox-5.1.14-112924-Win) and Vagrant 1.9.1 on my Windows 10.

The error is the following:

Timed out while waiting for the machine to boot

In order to avoid it I add a new line in vagrantfile:

config.vm.boot_timeout = 900

But error persists.

I also enabled the GUI removing the comment (according to the answer here):

vb.gui = true

However it returns a new error:

The guest machine entered an invalid state while waiting for it to boot…

I also followed this answer:

select Ubuntu server, click on Settings, go to Network tab and make sure that your Cable Connected option is selected

…and cable connected option was selected. However it shows this notifications:

invalid configuration detected

This is my Vagrantfile.

# -*- mode: ruby -*-
# vi: set ft=ruby :
Vagrant.configure("2") do |config|
  config.vm.box = "ubuntu/trusty64"
  config.vm.boot_timeout = 900

  config.vm.provider "virtualbox" do |vb|
    vb.customize ["modifyvm", :id, "--cableconnected1", "on"]
    vb.memory = "2048"
  end

end

Is there another method to solve this problem?

  • @techraf I did it a few times. Now I did it in a new directory but without luck. – Ramiro Tormenta Feb 26 '17 at 4:18
  • What version of VirtualBox 5.1 do you have? It’s up to VirtualBox 5.1.4 at this point. There are a lot of different patch versions out there that fix all kinds of stuff. – JakeGould Feb 26 '17 at 4:23
  • @JakeGould This is the version: VirtualBox-5.1.14-112924-Win – Ramiro Tormenta Feb 26 '17 at 4:26
2

For what I can see: you need to enable virtualization technology (VT-X) extensions in BIOS in order to run virtual machines.

Your Vagrantfile is fine to configure a new box. However, the problem about:

Timed out while waiting for the machine to boot...

...sounds like VT-X is disabled in your windows configuration (Basic Input/ Output System).

Try to enable this feature and box installation should works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.