1

I've ran into a "little" problem while I was trying to create a virtual machine (Windows Server 2012 R2). The reason why I am trying to create the virtual machine is educational (we need to do it thanks to the University I am studying at).

The problem I am facing is saying that Hyper-V encountered an error while configuring the network.

Please note that I already did check the services and the "Hyper-V Virtual Machine Management" is already set to run when Windows starts and it's set to automatic (and obviously is already running at the moment of talking). I am unsure on what to even try at this point because I can't find a possible solution to deal with this.

Has anyone had this exact sort of problem where the issue continued even after making sure the VM Management service is running? Also, I did check in my BIOS, and the VM option is enabled.

Image 1

Image 2

1

After trying about 4 suggested fixes, I managed to get Hyper-V to work again by following these steps:

  1. Disable/remove the Hyper V feature:

    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V

  2. Reboot

  3. Re-install the Hyper V feature:

    Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V -All

Source: https://knarfalingus.net/2018/07/01/hyperv/hyper-v-encountered-an-error-trying-to-access-object-on-computer

0

Can you post a screenshot of the VM settings, and a screenshot of virtual switches in Hyper-V virtual switch manager . Also, if you could provide more detail about the error message .

Please check if all Hyper-v features are installed :enter image description here

  • Hello! Actually, I am unable to even open the Hyper-V Virtual Switch Manager as it provides me with an error (i.imgur.com/6rx1u4o.jpg) which I have tried to find a workaround for, but was unsuccessful. As for the Hyper-V VM creation error, this is the screenshot of it: i.imgur.com/guSpgM6.jpg – TheDoomDestroyer Feb 26 '17 at 15:16
  • Sorry , but i can't view the images . Can you try to upload in original post using image button . – George_K Feb 26 '17 at 15:32
  • I have updated the original post. As for the Hyper-V Extensible Switch, it gets disabled after I click on OK. – TheDoomDestroyer Feb 26 '17 at 15:44
  • if all features are there , please try to create a virtual switch using powershell : New-VMSwitch -Name "External VM Switch" -AllowManagementOS $True -NetAdapterName Ethernet here is a usefull link: docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/… – George_K Feb 26 '17 at 16:02
  • I had tried that way, but I believe since I am using Wi-Fi (and am unable to use Ethernet in any way), it won't let me create a vSwitch (as I get a generic failure error). – TheDoomDestroyer Feb 26 '17 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.