0

WD My Passport Ultra is showing up a weird behavior. When i connect it with USB 3.0 it works perfectly without any issue. But when i try to connect it using USB 2.0 port it doesn't work. It shows up in device manager as

Unknown USB Device (Device Descriptor Request Failed)

In Device status it shows

Windows has stopped this device because it has reported problems. (Code 43) A request for the USB device descriptor failed.

I tried plugging it into other PCs and it didn't work. I'm using windows 10 x64. One month before it worked perfectly on USB 3.0 and 2.0. I tried it on Windows 7 PC too but it didn't work.

When i tried it in Ubuntu it worked perfectly in both 2.0 and 3.0. I don't understand what's wrong with my HDD. Is it a hardware issue ? Can some one help me fix this problem ?

  • 1
    It sounds like the USB 2.0 ports isn't giving it enough power... USB 2.0 ports are rated for 500ma, where 3.0 ports are rated for 900ma, but the drive is rated to work with ether one. If it doesn't work in multiple different PC's I would suspect a defective drive or cable. – acejavelin Feb 26 '17 at 20:31
  • 1
    @acejavelin He mentioned that it did worked for him with the USB 2.0 before, and also that it still work for him with the Ubuntu OS. So it's probably not any USB 2.0 electric fault (unless it's broken in some way, or the usb 2.0 chipset is problematic).. – Hashirama Senju Feb 26 '17 at 21:46
0

Please try to do the following:

  1. Try to plug it directly into one of the USB2 of the motherboard itself (on the back), and not into one of the USB2 of the case of the PC.
  2. While the HDD in plug into the USB3 try to uninstall the driver through the device manager.
  3. Unplug and plug the HDD to the USB2 and see if it recognize it and install its driver correctly.
  4. Use a different cable.
  5. Plug it to another USB port on the motherboard.
  6. Remove all of the partition that you have in the drive and format it completely to NTFS file system.
  7. Repeat all of the above once more.

The case may depend on which point of the process you managed to succeed and which you haven't.

  • It's already done. No change. – CodeIt Feb 27 '17 at 0:22
  • @CodeIt Is the USB 2.0 still work for you with the Ubuntu at your PC, or is it someone else PC's? – Hashirama Senju Feb 27 '17 at 5:15
  • I tried it on my PC as well as the PC's in our lab. It works well. – CodeIt Feb 27 '17 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.