0

I am using 3.5" HDDs connected through USB 3.0 fantec docking station as my backup storage. In the past I have set up LUKS encrypted ext4 partitions on 1TB and 2TB drives without problem. Recently I wanted to move to a 4TB drive (WDC WD40EZRZ-00W 0A80) and I am unable to do so.

I am running Arch Linux on a Lenovo y510p laptop with EFI firmware. In the Boot menu I have Boot Mode set to Legacy Support and Boot Priority set to Legacy First. All my disks M.2/NGFF SSD and two 2TB HDDs are listed in the Legacy section in the Boot menu. If I turn off the Legacy Support, no disks are listed. I use GRUB to boot both Linux and Windows. My boot, root, tmp, home and Windows partitions are on an M.2/NGFF SSD using MBR.

Up until getting the 4TB drive, I was using MBR partition tables on my backup drives. I initially used MBR on 4TB, but after encountering problems, I switched to GPT. I succesfully setup GPT partitions on 2.5" 2TB HDDs I have inside my laptop and set up LUKS with ext4 filesystems.

My workflows when setting up a backup storage were following:

  • cfdisk /dev/sd_, setup GPT, tried with:
    • 2x 2TB partitions, and
    • 1x 2TB partition,
  • use cryptsetup luksFormat /dev/sd__ and add a passphrase,
  • open the encrypted drive with cryptsetup luksOpen /dev/sd__ backup,
  • mkfs -t ext4 -L backup /dev/mapper/backup,

So far so good, the fsck runs without error. In case with two partitions I was able to use rsync to backup to the first partition, still fsck run without errors. After rsync-ing the second one, the boot record was gone and fsck on both was failing. With one partition rsync failed in the middle with filesystem corruption errors.

The only idea I have left is to disable the Legacy Mode, but that would probably require reinstalling both systems and a bootloader. Is there anything else I have missed?

EDIT: When I unmount and plug-in the disk again, the partitions are gone. cfdisk recognizes the disk as having empty MBR partition table. That happened both with single partition and two partitions setup.

EDIT: It is not LUKS related, I have tried again with plain ext4 partition and it failed. The GPT partition was wiped out during copy to the second half of the disk, the rsync aborted with write errors, dmesg output here. After disconnect and reconnect the cfdisk comes up with menu to choose partition type.

  • boot mode should have no bearing on non-system filesystem troubles, don't change it. are you sure the new drive is good? are you sure the dock is good? try accessing the drive in another dock. what rsync commands are you using? – quixotic Feb 26 '17 at 16:37
  • @quixotic I gave the drive and the dock to the admin at work, he couldn't reproduce my problem, but didn't use encryption. I'll try again without encryption. I'm using -av or -a --progress, some --excludes and --one-filesystem, nothing particular. – dhill Feb 26 '17 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.