0

I created a script to launch VLC at system startup (Ubuntu 14) , to reproduce continuously some videos, however as soon as the internet connection is established teamviewer (11) shows up breaking the full screen mode.. how can I hide it and keep VLC on top? Thank you

EDIT

More details..This is a Kiosk which has only to show infinite loop videos, and Teamviewer is only installed for remote management, so it has to start with the OS. So videos has not to be interrupted by any kind notifications (of course this is not the case is I connect to the machine with teamviewer for management).

  • Do you mean TeamViewer is installed on the computer and when an internet connection is established it pops up? Or do you mean that when someone connects to this computer via TeamViewer it breaks the fullscreen of VLC? Does TeamViewer have to start with the OS? Is this a kiosk computer that is only supposed to play infinitely looping video? A little explanation of what you're trying to accomplish could help us put together a better answer and solution. – music2myear Feb 27 '17 at 17:53
  • Edited with more details. Please see.. – rok Feb 27 '17 at 18:00
  • I haven't used TeamView in a while. Does it actually pop up an application box you have to dismiss, or does it just pop up a message that goes away but has already broken the VLC fullscreen? – music2myear Feb 27 '17 at 18:06
  • If TV just pops up a message, have you tried running the VLC video as desktop background and setting the taskbar to autohide? howtogeek.com/howto/18167/… Also, what OS/version are you running? – music2myear Feb 27 '17 at 18:08
  • I'm using Ubuntu 14, TeamViewer opens a little window that stays on top of the full screen.. – rok Feb 27 '17 at 18:10
1

First, I'm assuming that TeamViewer has a setting to allow it to run without popups. For the paid-for version I would consider it exceptionally unlikely they would not allow this as an option. So look through your TeamViewer settings for this, or check out the answer to that problem here: How to hide the notifications of the Teamviewer (silent use)

The basics of this solution are to open TeamViewer Options > Advanced > And enable "Automatically minimize local TeamViewer panel.

Second, run VLC as the desktop background, which is also doable in Ubuntu: https://askubuntu.com/questions/565154/how-to-set-a-mp4-as-a-wallpaper

The gist of this solution is to launch VLC from the terminal using the command cvlc --video-wallpaper /path/to/your/video

Third, hide the Ubuntu launcher and menu bar like this: https://askubuntu.com/questions/9865/how-can-i-configure-unitys-launcher-auto-hide-behavior

Install the CompizConfig Settings Manager, under Desktop find the Ubuntu Unity Plugin and set Hide Launcher to AutoHide.

=================

Running the video as background will make it more resilient in that interruptions on the desktop will not interrupt it or exit full screen. Then, of course, you have to hide the various UI elements so that they aren't overlaying the video.

Finally, programs popping up on login is just bad behavior in general and should never happen by default.

While the first step should negate the need for the other two, I'd personally implement all three to make the entire system more uninterruptable in general.

  • 1
    That option in Teamviewer is related to incoming connection, if someone connect to that PC the panel minimizes automatically.. Btw I found another useful option "Show computers and contacts on startup" to deactivate to make it works (That is the annoying popup) – rok Feb 28 '17 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.