1

I have a Fedora 20 virtualbox guest installed on a Windows 7 host. Recently I found the host machine lost sound device and couldn't play any music sometimes. When this happened, I saw the guest Fedora 20 is using the sound device by looking at the Windows Volume Mixer. But actually nobody plays any music on the Fedora guest at that time. I only use it to run a console application without any needs for sound.

So how to prevent virtualbox guest from using the host sound card?

EDIT:

From the host and guest settings, which audio controller I should select if I don't want to completely disable the Audio for the guest? Intel HD Audio should be the right one? My host is a Lenovo W540 laptop.

My host sound settings:

enter image description here

The guest audio settings:

enter image description here enter image description here

EDIT2:

With the Intel HD Audio the virtualbox guest does still prevent host applications from using the sound device even there is nobody actually use sound device on the guest.

My virtualbox version is 5.0.26. not too old.

2

When your Fedora VM is turned off, select it using a single mouse-click from the list of VMs in the VirtualBox GUI.

Then click on Settings (the yellow cogwheel).

In the window that opens, click on Audio and then deselect Enable Audio.

This disables audio for your Fedora VM.

  • I have updated my post. any suggestion if I don't want to disable guest's audio? – peterboston Feb 28 '17 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.