9

I've setup a VM that works great except for the auto resize functionality which seems to be inconsistent. I've got it randomly working a few times but it also randomly stops working. It's currently not working and I'm not sure what I need to do to get it to work reliably (like VirtualBox autoresizing). Please see below for my configuration.

setup

Host: Ubuntu 16.10
Guest: Ubuntu 16.04.2, et. al (I've tried with other Linux distros with similar results)
Guest: created using virt-manager
Guest: installed spice-vdagent
Guest: virt-manager > View > Scale Display > Auto resize VM with window (checked)

spice

user@ubuntu:~$ ps aux | grep spice
root       805  0.0  0.0  30568   260 ?        Ss   08:59   0:00 /usr/sbin/spice-vdagentd
user      1365  0.0  0.0  35124  2360 ?        Ss   08:59   0:00 /usr/bin/spice-vdagent
user      1933  0.0  0.0  21292  1020 pts/17   S+   09:00   0:00 grep --color=auto spice

qxl

user@ubuntu:~$ sudo lshw -c Video
  *-display               
       description: VGA compatible controller
       product: QXL paravirtual graphic card
       vendor: Red Hat, Inc.
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 32 bits
       clock: 33MHz
       capabilities: vga_controller rom
       configuration: driver=qxl latency=0
       resources: irq:10 memory:f4000000-f7ffffff memory:f8000000-fbffffff memory:fc058000-fc059fff ioport:c040(size=32) memory:c0000-dffff

What am I missing to correctly enable auto resize with qemu/kvm?

5

[workaround]

I too have struggled with this. I find that if I use spicy (spice-client-gtk) and this command

xrandr --output Virtual-0 --auto

it does do the resize right if vdagent is installed on the host and the guest and the qxl driver are installed. I have taken to putting a shortcut to that command as an item in my menu or panel. (making sure that that thing is in the upper left corner so I can always get to it.)

But I can't see any event to watch to automatically do the resize. Windows 7 and Windows 10 guests do it perfectly. Why not linux????

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.