0

I currently have an HP Compaq dc7600 sff computer that has fedora 24 installed with grub on it (which is not the OS it comes with). I'm trying to install Windows Server on it, so I burned Windows server to a DVD+R DL 8.5GB disc, put it in the Disc Drive, which by the way, is a generic HP CD/DVD-ROM disc drive, and went into the bios boot menu (F9) and booted from CDROM Drive, which is a valid and listed option. I have also tried the setup menu (F10) and changed the boot order. Instead of booting to the windows server installation media, it hangs at the blinking underscore (__) symbol for a while then continues to grub on the hard drive

If I try the same thing but with a USB instead of a DVD, it just skips it and loads grub instead.

If I disable booting from the hard drive from the setup menu (F10) or unplug the hard drive SATA cable and then try to boot from either the USB or DVD, it just tells me:

Non-System disk or disk error
Replace and press any key when ready

Pressing any key displays the same message.

I know the boot media works, and just in case it's not compatible with windows server or dual layer DVDs, I even tried a fedora workstation live media on a regular DVD+R, which is the same OS it's running yet the same thing happens. The disc drive even has the DVD-ROM symbol on it, so I know it's compatible, and there must have been some way to install fedora 24 on it in the first place (I'm not the one who installed fedora).

Is there some other compatibility issue I've missed? Even under device settings in the bios, it lists the correct name of the DVD and the USB. Do I need to burn the installation media in a certain way? What can I do so that it boots from the DVD?

1

It sounds like your Windows Server disk image is not bootable - thus the Non-system disk error.

When burning with commercial software, there is often an option to make the resulting disk bootable, which should be selected in your case. Not sure the exact way to do it with your linux, but this site shows Windows examples

http://www.makeuseof.com/tag/make-bootable-usb-cd-dvd-install-windows-using-iso-file/

  • I used PowerISO on windows to burn the disc, and it said bootable media in the bottom left. Do I need to use another program or search up how to change this setting in PowerISO – Abob Mar 1 '17 at 6:10
  • Actually, you were right. I used Rufus to create a bootable USB thanks to the guide you linked and now it boots from it properly. Too bad I spent so much on dual layer dvds – Abob Mar 2 '17 at 2:02
0

This computer is very old which means also his DVD-Drive, try burn in ISO MOde not UDF.

TRy to boot from CD, i bet it works.

Same for Old USB Chipsets, cant boot from big Drives, u can try an old small 1GB stick maybe.

  • CDs are too small, the installation media is about 6 GB. Same goes for the USB. Also how would the size of the USB matter? And like I said it does detect the name which means it can read it, it just fails to boot from it. I can see what you mean but I have to use DVD+Rs – Abob Mar 1 '17 at 16:28
  • Size matters because old chipsets cannot handle usb media with a size which wasn't available on the market when there usb-chipsets were manufactured.... – Wess Mar 7 '17 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.