0

I recently bought a Samsung 960 Pro NVMe SSD (512GB) primary cause of its extremely high sequential read/write speeds. I usually convert videos to lossless format (GPU accelerated) so IOPS is the only bottleneck and 960 Pro's 2100MB/s Sequential write looked tempting. However, I cannot get anywhere closer to that speed for large file transfers. CrystalDiskMark shows good numbers however the real-world transfers are maxing out at 390MB/s.

For my test, I am using a 20GB file on a RAMDisk which has read speeds of ~9000MB/s so there is definitely no bottleneck there. My Interface is PCIe Gen. 3 x4 as confirmed in Magician, Trim enabled and so is Write Caching in Windows. Write cache buffer flushing is also enabled [unchecked] (as it reduces performance for NVMe SSD's instead of increasing it like SATA SSDs) [I tried disabling it as well but to no avail]. Lastly, I have Samsung NVMe 2.1 Driver installed. My Windows is a fairly clean installation and I performed NVMe Secure Erase on my SSD prior to installation.

Here is a screenshot of CrystalDiskMark (3 passes, 4GB each):

https://i.stack.imgur.com/z9B8F.png

As can be seen, sequential performance is awfully close to advertised performance however I cannot replicate that for real-world transfers. Last, but certainly not the least, I have BitLocker enabled (software encryption as Samsung still hasn't enabled IEEE1667 on this drive) and I understand there is a bit of overhead because of that but 390MB/s instead of 2100MB/s cannot be caused by BitLocker alone!

Any suggestions?

  • I assume you really meant MB/s (or even MiB/s) every time you wrote “Mbps” (which is really MBit/s), so I replaced all occurrences. // Please also provide the exact version of Windows. // Also, try without Bitlocker. – Daniel B Mar 1 '17 at 13:15
  • Here's a comment that you might be interested in: superuser.com/questions/1183622/… Its under my answer. – RamonRobben Mar 1 '17 at 16:00
  • @DanielB: Thanks for the correction. Its just a very bad old habbit. I tried without BitLocker and there was a slight bump (~420MB/s) but that still doesn't explains the massive performance loss. – Umer Mar 1 '17 at 18:27
  • @RamonRobben: That link is for drives in RAID 0 configuration whereas mine is a single NVMe SSD. – Umer Mar 1 '17 at 18:29
  • Mainstream motherboards share the same DMI 3.0 (~4 GiB/s) lanes for the M.2 slot, SATA ports, and other peripherals. High-end boards typically use the CPU's dedicated PCIe lanes at least for one M.2 slot if not all. So even though an M.2 drive is connected at PCIe 3.0 x4, the maximum combined throughput to all drives, the network adapter, USB ports and several other components is limited to ~4 GiB/s on a mainstream board. – Monstieur May 23 '17 at 7:25
0

I actually found the issue. It was TeraCopy. I've been using TeraCopy for many years now and I just released that it doesn't uses Windows Write Cache by default. I am now getting speeds in excess of 1.6GB/s. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.