0

I have a MS Word 2016 book manuscript with lots of citations. I'm using the APA Style but want vary from it to suppress the year in citations for authors with only one entry in my bibliography. E.g., change the field

{ CITATION Car77 \l 1033 }

to

{ CITATION Car77 \y \l 1033 }

(I looked at editing the APA*.xsl file, but it looks like more work than doing global find and replaces.) However, if I invoke's Word's Replace dialog, fill in the "Find What:" and "Replace With:" with the text that should do the job (e.g., "Car77" with "Car77 \y"), every time the find lands within field text, the "Replace" button gets disabled.

There are discussions on using ^c and ^d and other tricks, but none work for me as the same thing happens with each one: it finds a field or text within and the "Replace" button goes gray. (Maybe a newer "feature"?) The "Replace All" button stays active, but clicking it invariably results in 0 replacements.

0

Take the text from the document itself and use copy-paste in the both fields and only add the \y in the second one.

That should take care of any hidden things / strange format compatibilities.

Also make sure to check the Review tab and then on the Restrict Formatting and Editing, an unprotect option should be available there, in case it's activated.

Alternate way - only if there are no special characters or fonts - copy-paste everything into a text file, make the replacement and copy-paste back.

Another trick to try is to change the font to something more standard (like tahoma), make the change and then set the font back.

Make sure theres no selection at the moment of your replace, because the replace operation will work only within that selection.

Make sure there are no search modifiers (match case and whole word) selected.

If you have complex formatting, this may be the actual cause of you problem. If you really do no want to lose that, last thing to try is copy-paste the content to another blank document, save it, close winword, reopen the new document and retry the replace.

  • Overmind, thanks for the thoughts but I had tried to copy-and-paste for both fields. Does it work for you in Word 2017? I hadn't checked the Restrict settings, but they're fine. Your text doc is a good one, but I'd lose all my styles, so not an option. – buttonsrtoys Mar 1 '17 at 16:12
  • Check, it may interfere. Yes, most of the time having the correct option and doing the copy-paste trick works. I will update the answer with some more things. – Overmind Mar 3 '17 at 6:34
  • Thanks for the thoughts. I did a test where I created a new blank doc with Times New Roman, added a reference, and then cited it a few times and still the same result - can't do a global find/replace of the field. (In the process, I saw I'm using Word 2016, not 2017, and corrected my original post.) – buttonsrtoys Mar 3 '17 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.