3

Since a few months I'm having an annoying problem with my Windows 10 installation. I can't simply open drives (either HDD or USB ones) labelled with the letters J: and K: from the File Explorer. When I try to do that, the infamous "This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator." message is appearing.

However I'm the system administrator and, moreover, I can access drives characterized by those labels simply using the Command Prompt.

Command Prompt

So, when I use a USB drive, first of all I need to change its label to just another one and then I'm able to gain access to it. Any hints about how to solve this issue?

UPDATE: I've created a new administrator account and it doesn't seem to have this issue. I can access to a drive having J: or K: labels.

5
  • have a look at stackoverflow.com/q/7145816/5976576 – MotKohn Mar 1 '17 at 18:47
  • “Restrictions” and “by administrator” usually refers to Group Policy. While you can certainly change it, it is still very much effective for all users. I don’t know which policy would cause this. – Daniel B Mar 1 '17 at 18:47
  • if you log in as another user, does it behave the same way? How about in Safe Mode (while logged in as yourself)? – Ƭᴇcʜιᴇ007 Mar 1 '17 at 19:13
  • Check Control_panel/Internet_options ->Security tab->Restricted sites->Sites Do you have there these drives? Check also this link – Alex Mar 1 '17 at 19:48
  • Nope: it's completely empty. – Davide3i Mar 1 '17 at 19:52
4

The only way you would receive this error is because of the Prevent access to drives from My Computer group policy.

enter image description here

The solution is to set User Configuration\Administrative Templates\Windows Components\File Explorer\Prevent access to drives from My Computer to be Enabled and set the option value to Do not restrict drives from within the Local Group Policy Editor.

enter image description here

enter image description here

If you enable this policy, users cannot view the contents of the selected drives in My Computer and Windows Explorer. Also, they cannot use the Run dialog box, the Map Network Drive dialog box, or the Dir command to view the directories on these drives.

The group policy in question is suppose to prevent the contents of the directory from being listed even in a command prompt. In my testing before writing this answer, even when I specifically set the option to Restrict all drives, I was given the contents of the drive on Windows 10 within a non-elevated command prompt.

Prevent access to drives from My Computer

Additionally

The default values are not the only values that you can use. By editing the System.adm file, you can add your own custom values. This is the portion of the System.adm to be modified

So going under the assumption that, somebody modified System.adm itself, and specifically added a custom numerical value of ‭1536 which is a 26-bit binary value of 00000000000000011000000000 this would explain the error message you are getting on the drives in question.

The default location of the System.adm file for a default domain policy is:

%SystemRoot%\Sysvol\Sysvol\YourDomainName\Policies{31B2F340-016D-11D2-945F-00C04FB984F9}\Adm\System.adm The contents of these folders are replicated throughout a domain by the File Replication service (FRS). Note that the Adm folder and its contents are not populated until the default domain policy is loaded for the first time.

Using Group Policy Objects to hide specified drives

The physical location of these templates might be different depending on the version of Windows your DC is using

0
1

If you have not configured Group Policy on your PC, try clearing the cached settings in the registry.

These are located here:

HKEY_CURRENT_USER\Software\Policies
HKEY_LOCAL_MACHINE\SOFTWARE\Policies
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies

If you have deliberately configured Group Policy try accessing the local Group Policy editor by running gpedit.msc. Choose All Settings and filter by the enabled settings to try to determine the settings causing this.

If the PC is connected to a domain, try removing it from the domain and clearing the cached settings as described above.

1
  • I've not configured any Group Policy; still, I don't see any cached settings in the registry keys you've reported me: only the default key can be seen. – Davide3i Mar 1 '17 at 19:07
1

This is probably due to the following Group Policy setting:

Subtree: User Configuration\Administrative Templates\Windows Components\Windows Explorer Setting: Hide these specified drives in My Computer

In newer versions of Windows, the Windows Explorer part has been renamed to File Explorer.

7
  • I've never configured said setting, so I just see "Not Configured". Moreover I can see those drives in the File Explorer: I can't simply access them by the usual ways. – Davide3i Mar 1 '17 at 19:08
  • Also check: User Configuration\Administrative Templates\Windows Components\Windows Explorer\Prevent access to drives from My Computer – Ƭᴇcʜιᴇ007 Mar 1 '17 at 19:13
  • That one is also set to "Not Configured". :/ – Davide3i Mar 1 '17 at 19:24
  • You should check the report from the gpresult tool (use the /h option to create an HTML report). – Bill_Stewart Mar 1 '17 at 19:54
  • 1
    Update your question, and verify that, \Windows Components\File Explorer\Prevent access to drives from My Computer` is specifically Enabled and set to Do not restrict drives. If you are connected to an Active Domain make sure the group policy on the domain controller is specifically Enabled and set to Do not restrict drives – Ramhound Mar 1 '17 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.