3

I have a TP-Link USB 3.0 7-Port Powered Hub UH700 with 7 devices connected. I have the hub connected to my laptop via a Belkin USB 3.1 Type-C to Micro-B cable. The hub works fine for a couple of seconds (sometimes minutes and sometimes even hours) and then disconnects. When it stops working, I can see the error 'USB device not recognized' and in Device Manager it shows, 'Unknown USB Device (Port Reset Failed)'. I have tried everything, literally everything but to no avail!

So far I have tried:

  • using a different USB 3.0 7 port Powered Hub (TeckNet),
  • using a different USB 3.0 Type-C to Micro-B Cable (CableMatters),
  • using a different 6A Power Adapter for the hub,
  • using only one low powered device on the hub (different devices as well to eliminate the possibility of malfunctioned device),
  • uninstalling and reinstalling USB devices when they are functioning normally,
  • uninstalling and reinstalling USB devices after failure occurs.

I am using Windows 10 on my Alienware 17R4 and my USB Selective Suspend is Disabled in Power Plan and I have also unchecked 'Allow the computer to turn off this device to save power' for every single device under 'Universal Serial Bus Controllers' and also under 'Human Interface Devices'.

Furthermore, I tried connecting voltmeter to my USB connector and can confirm that my hub with all devices connected at the same time is taking 0.0 amps from the USB connector and about 1.4 amps when hub is un-powered. Nevertheless, like I mentioned, for testing purposes I only have one non-faulty USB device connected to the hub in which case power draw is 0.0 amps when powered (surprise!) and 0.2 amps with the mouse connected.

The hub, when connected to laptop with a USB 3.0 Type A to Micro-B cable generates the same error (Port reset failed one) but continues to work! However, I do not get USB 3.0 speeds after the error. In fact, they drop to even lower than USB 2.0 speeds.

The hub, when connected via USB 2.0 to Micro-USB cable, works absolutely fine. Been using on USB 2.0 for about a week now with no issues but can't manage to get this working on USB Type-c.

Any suggestions would be greatly appreciated.

P.S. I really want to get this working on USB Type-C since my Type-C and Power Connector is on the back of my laptop and I really don't like the cable sticking out from the side.

  • Which controller IC is inside? Does the case go warm when it disconnects? – Ale..chenski Mar 2 '17 at 2:13
  • @AliChen: I'm assuming you mean USB hub? Its got VIA VL812 which is apparently one of the most widely used chipsets for 7 port powered hubs. It doesn't get any additional warm when the issue happens and like I said, I tried a different hub as well! – Umer Mar 2 '17 at 2:29
  • The VL812 is a 4-port hub. Are there two cascaded chips inside? And the different hub also fail, right? Do these hubs carry USB-IF Super-Speed certification logo? I don't see anything on the boxes. If not, exactly this kind of things do occur. Sorry. – Ale..chenski Mar 2 '17 at 3:48
  • Yes, there are 2 chips inside. I have another hub from Plugable which has USB-IF SS Certification however that one causes the exact same issue as well. – Umer Mar 2 '17 at 8:19
  • I have a Buffalo USB 3.0 4-port hub, and it also goes into la-la land sometimes, and recovery takes a lot of efforts, power off-on, cable off-on, USBTreeview resets and disables (with a message "port reset fails"), I am not sure what happens. It sounds like the USB 3.0 technology is not matured yet, at least your laptop is three generations behind, and the Intel USB technology is not a standard of excellence. – Ale..chenski Jul 7 '17 at 17:08
0

I have exactly the same hub,and I'm on a one year old HP Omen machine, and Windows 10 64-bit with all the latest updates.. I am having the same issue as the original poster of this topic.. My blaming finger turns towards Microsoft. :P

I know passive hubs (=without own power supply) do disconnect the drives since it can not draw enough power for them from one usb port (500mAh),but since this is active hub with it's own power supply, it really shouldn't be doing this stuff... I already replaced the hub once, since I thought I had a faulty one...

  • 1
    Welcome to Super User! This isn't an answer to the question, so it is likely to be deleted. If you have a new question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you can track any new answers on your user profile page. – fixer1234 Apr 13 '18 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.