0

I just got CenturyLink gigabit fiber. I used to have Comcast. When CenturyLink set me up, they gave me their own router. I'd like to use my own router: a Netgear R7000 running Tomato (AdvancedTomato).

I used my R7000 router just fine on Comcast where the setup is simple: plug the cable modem's Ethernet connection into the router's WAN port and DHCP does everything. CenturyLink uses PPPoE and a specific VLAN to connect, so per some guides I've found, I made the following changes:

  • I set up the WAN port with a VLAN VID of 201.
  • I enabled VLAN tagging for WAN.
  • I set the VLAN ID for WAN to 9 (this might have done nothing; it was part of the troubleshooting).
  • I enabled PPPoE using credentials CenturyLink provided for me.

My VLAN configuration looks like this:

Tomato VLAN settings

I can connect to Wifi on the router just fine and I can access the Internet. However, the LAN ports in the router's built-in switch are completely ignored by the router. The light comes on (there's a link), but I don't get a DHCP IP. If I set my Ethernet adapter manually to a static IP on the 192.168.1.x subnet which is my default LAN subnet, I can't even ping the router.

I know for sure the Ethernet adapter I'm using works and the router itself has a working switch because I've used it with Comcast just fine. I'm connected directly to the switch on Ethernet with no other switches or cabling in the way. You can see the connection here:

Tomato port status

192.168.2.x is a guest network so it can't talk to my normal LAN devices on 192.168.1.x but can still get to the Internet.

I have tried to:

  • Set the VID and VID Offset to 192 as one forum post suggested. It made no difference.
  • Plugged into other ports on the router's built-in switch to no effect.

Windows says this for the broken Ethernet connection:

Ethernet adapter USB Ethernet adapter:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::89b2:5d40:4da7:7728%16
   Autoconfiguration IPv4 Address. . : 169.254.119.40
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

...and this for the working Wifi connection:

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::29ed:7cd2:2142:5bd5%14
   IPv4 Address. . . . . . . . . . . : 192.168.1.109
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

I'm completely confused. Any ideas?

  • Question, why do you need VLAN's? Also, if you have your own router setup with Tomato, you should just be able to shut off dhcp, assign all interfaces to the same bridge (Even the routers WAN port) and get dhcp assignment from the Modem/Router they provided, or you could just plug your routers WAN into one of their lan ports. – asmith Mar 2 '17 at 6:25
  • Ignore me, I did not read your question right, one sec and I will make sure I understand, I see you said they use VLAN's I will read this over again and better – asmith Mar 2 '17 at 6:27
  • At first glance, I would think you would also need to tag your LAN bridge to also use this VLAN, just a thought – asmith Mar 2 '17 at 6:28
  • Doesn't the CenturyLink Modem/Router already do the necessary VLAN tagging to the ports on their own router? So no VLAN tagging would need to be done at any other device after – asmith Mar 2 '17 at 6:31
  • My goal is to replace the CenturyLink-provided router entirely. There's a fiber ONT on the outside of my house that, in effect, converts the optical fiber connection to Cat 5e cable running into the house which is plugged into the WAN port on my R7000. To be perfectly honest, I only understand VLANs at a very high level, so the fix could be simple but just eluding my limited knowledge. – user3466413 Mar 2 '17 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.