1. Briefly

I don't find, how I can run ConEmu + Far in current folder.

2. Detail

  1. I don't set ConEmu + Far in ConEmu Open Sublime Text package.
  2. I don't set, how ConEmu + Far open in ConEmu Here.

3. Did not help

  1. Sublime Text package have a line:

    command= "start conemu.exe /Single /Dir \""+dirname+"\" /cmdlist powershell -new_console:t:\""+title+"\""

    PowerShell run for me in current folder. If I replace in this line powershell to cmd → default console run for me in current folder. But If I replace in line powershell to far → ConEmu + Far open for me in C:\Program Files\Far Manager — my folder with Far Manager.

  2. I try set ConEmu Here for Far like for Git Bash. For Command parameter I set values

    Far ConEmu

    • /Single -run {Far}
    • /Single /cmd {Far}

    ConEmu + Far open for me in C:\Program Files\Far Manager — my folder with Far Manager.

4. Environment

Operating system and version:
Windows 10 Enterprise LTSB 64-bit EN
170118 [64]
Far Manager:
3.0 build 4774 x64


  • 1
    After trying to resolve similar problem myself, I suggest you to try another open sourced project ConsoleZ. It is well maintained fork of abandoned Console2, and it has similar features you found in ConEmu. – Alex Mar 7 '17 at 6:21
  • @Alex: BladeMight solution works for me. Thanks. – Саша Черных Mar 15 '17 at 6:26

This is VERY simple! Just make a {far} task like so(basically path to your far):

and then in integration tab use these configurations to create ConEmu Far Here:

As you can see in image above, command {far} . runs far in current folder, and then it executes new ConEmu tab with -cur_console:n command. Or you can even configure your task to run with dot as parameter: C:\path\to\far.exe . and then just use it in integration or even from ConEmu command line like so:

"C:\Path\to\ConEmu.exe -run {far}"

and it will start far in current directory, even if called from explorer address-bar.

  • BladeMight, I make an actions as in your answer → I run Far + ConEmu in a folder → result. I press Ctrl+Oresult. How I can get result as in image 2, that I can't press Ctrl+O every time as I run ConEmu + Far? Thanks. – Саша Черных Aug 4 '17 at 4:51
  • @СашаЧерных По поводу Ctrl+O после запуска, добавьте этот Macro в %FARHOME%\Macros\scripts. (%FARHOME% - там где far.exe) – BladeMight Aug 4 '17 at 11:03
  • @СашаЧерных Еще более легкий вариант, нажмите Shift+F9(сохраните настройки) после Ctrl+O и при следующем запуске Far он будет уже без панелей. – BladeMight Aug 4 '17 at 11:05
  • BladeMight: both methods doesn't work for me. // 1. I create lua file → I close ConEmu → I run Far Here in any folder → I still need press Ctrl+O // 2. I open Far+ConEmu → I press Ctrl+O → I press Shift+F9 → I close ConEmu → I run Far Here in any folder → I still need press Ctrl+O. // I repeat both actions 3 times → I don't get expected behavior. Thanks. – Саша Черных Aug 6 '17 at 5:47
  • @СашаЧерных Does pressing Shift+F9 saves settings(calls save settings dialog)? If not then save them after you change mode to Ctrl+O through menu -> "Settings" -> Save settings, and it will save it, so next time you run it, it will have Ctrl+O mode enabled already. If you can't display Far's menu(its hidden by default) click with mouse a bit lower than the ConEmu tabs(e.g. at top of Far window). – BladeMight Aug 6 '17 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.