1

I'm trying to install Weblogic using the Quick Installer. According to the README file I shoudl first set my JAVA_HOME system variable.

QUICKSTART

  1. Setup JAVA_HOME for the target platform.

So, consider this done.

enter image description here

If run %JAVA_HOME% in my terminal I can verify that.

enter image description here

But when I run the installer it point to the Java Runtime path.

enter image description here

Why is that ?

  • 1
    Try running this and see if it works "C:\Program Files\Java\jdk1.8.0_121\bin\java -jar fmw_12.2.1.2.0_wls_quick.jar" (including the quotes). – n8te Mar 2 '17 at 11:56
  • @n8te Yeap, so easy, you are right. So how to avoid this ? Do I have to make any adjustments ? Change the JRE_HOME or something ? – giannis christofakis Mar 2 '17 at 12:03
  • It's unclear to me without being able to see some of your other settings why it is trying to run the install from the jre directory instead of the the jdk one. Maybe jre is listed in your %PATH% and that is superseding the JRE_HOME? Just a guess. – n8te Mar 2 '17 at 12:05
0

Although it is unclear why the installer is looking in the jre directory instead of jdk, a simple workaround for installing Weblogic is to simply run this command:

"C:\Program Files\Java\jdk1.8.0_121\bin\java -jar fmw_12.2.1.2.0_wls_quick.jar"
0

Environment variables don't propagate changes instantly, they are set once when a process is started and don't change anymore unless the process itself does it.

If you have opened that cmd window before setting new JAVA_HOME, then it's probably still using the old value. You can check that by running echo %JAVA_HOME% in that cmd.

If you want to quickly ensure that all env variables are up to date across the system, then just log out from Windows and then log in again. The quicker way would be to run set JAVA_HOME=<valid_path_here> in that cmd, but it will update it only there and in programs started from that cmd.

  • I've tried both way you proposed in vain, if you see I echo the correct java home path in my question. – giannis christofakis Mar 2 '17 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.