1

So I have been having some troubles with Java. It turned out I had the 32 bit version installed of jdk, not sure why. I uninstalled it to install the 64 bit version instead. However I can't get the installation to work. The installation .exe is not doing anything. When I click it I get the prompt from Windows asking if I'm ok with them making changes to my device etc. I click yes and nothing happens at all. This has happend with the newest versions of JDK and JRE, older versions of JDK and JRE, openjdk and even netbeans refuses to install JDK. Checked the processes to see if anything Java related was running, but there wasn't. Not getting any error messages either except for the netbeans installation which gives me an error code: -80.

Tried to google it, no results. I have checked various websites to no avail. Tried to check if I uninstalled the 32 bit version correctly, which I seem to have done. Tried using registry cleaners, did not help. Tried turning off background programs, did not help. I don't know anymore what I could try right now to fix it and since it's not really clear what's going on and what's causing the problems.

I am using Windows 10 64 bit.

I have been stuck with this for quite a while now and I really want to fix it. I hope someone here knows something I could try or what is causing the issue. To me it seems the only option I still have left is to reinstall Windows completely which I do not really want to do..

EDIT: I should note that I have also tried to apply the solution here: Java JDK 7u4 64 Bit Install Not Launching I am not entirely sure however what is meant here by "deny delete/delete sub for each listed role/user" So this did not work for me.

  • Did you try to execute the installation .exe as administrator? – IQV Mar 2 '17 at 14:57
  • @IQV Forgot to mention it, but yeah I have tried that. – Bartel-jaap1234 Mar 2 '17 at 15:05
  • Did you ever figure this out? I'm getting this code on a Java JRE install. – Travis Jul 12 '18 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.