Today I spent more than an hour trying to get Skype set up on my Linux box (Debian testing), but I couldn't make my microphone to work correctly. So I hear the other person talking, but they can't hear me. I am running KDE 4.3 and Skype 2.1 Beta. What do I need to do to get it working?

  • 3
    Does the microphone work in other applications? – Nifle Mar 10 '10 at 22:30

I've used audio with Skype and GNOME before. I'm suspecting you don't have the audio input set properly. Open options (ctrl+o) and go to sound devices, check the input there. Likely that's set to PulseAudio, Ideally KDE needs to use the same audio system.


It turned out that my microphone didn't work in any other application either. After some fiddling with mixer settings, I found out that the Capture switch was disabled and muted. After fixing this and setting Front Mic as the Input Source everything started working.

Its a bit of a shame that the default mixer settings are still not what the average user would expect.

Thanks for the hint @Nifle

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.