1

Caps Lock is always enabled after Windows 10 starts up. I try to edit Registry as suggest in the web to set initial keyboard value to 0. But every time I restart the computer, the Caps Lock is on and the initial keyboard value in Registry goes back to 2 again.

I have switched Caps Lock with the left Control using keytweak. After I switch back, the problem is gone. But this doesn't make any sense, or why does this happen?

Here are the THREE question:

  1. Why the initial value of "InitialKeyboardIndicators" in Registry is always set to 2 after I have changed it to 0.
  2. How can I have Caps Lock turned off when the computer boots, at the same time keep Caps Lock switching with the left Control?
  3. Why does this happen? Under the hood, what is the relation between the key in a keyboard with the computer inside?

This is the picture from keytweak

  • Some computers have a setting in the BIOS for CAPS lock on startup. Did you check this? – JoelAZ Mar 5 '17 at 9:08
  • 2 does not mean Caps Lock on. It means Num Lock on. Caps Lock on is 1. Of course, that's for Windows 7. Did you try setting the value to 80000000? – user477799 Mar 5 '17 at 10:52
  • On the closer inspection of the article to which you linked, the article suggests 2147483650 for Windows 10. Did you try that? – user477799 Mar 5 '17 at 11:02
  • @FleetCommand I have try them all. The issue is every time I restart the value back to 2again, no matter what number I have set. – EvanL00 Mar 5 '17 at 11:52
  • @JoelAZ My computer is Acer, and I press F2 into the BIOS, but found none setting related to the capslock(or keyboard). – EvanL00 Mar 5 '17 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.