3

I'm trying to mount a hard disk (SATA-3), but I rest stuck at the error:

NTFS signature is missing

Is it possible that a hard disk is protected by a password or has another kind of protection? How should I check if this is the case? And if it is yes or not protected is there a way to mount the disk anyway and retreive the files on it?

Below: the things that I've already tried and as much as error information.

I'm working on Linux (Mint 18.1).

First some background information:

I have an older commercial hard disk recorder (Pioneer DVR-LX61) and its HDD has no space anymore, it's full; I want to move the recorded video files to my computer. I linked the HDD-recorder to my network, but I couldn't mount the disk as it asked me for a password for user root. I took the hard disk out the recorder and connected it directly to my motherboard (with SATA-3 connection). I'm now trying to mount it, but I get into the mentionned errors.

This is what I've done so far:

mycomp@mycomp ~ $ sudo fdisk -l
Disk /dev/sdc: 232.9 GiB, 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start       End   Sectors   Size Id Type
/dev/sdc1  *        4 488397167 488397164 232.9G a5 FreeBSD

mycomp@mycomp ~ $ sudo mount -t vfat /dev/sdc1 /mnt/
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error

In some cases useful info is found in syslog - try
dmesg | tail or so.

mycomp@mycomp ~ $ sudo mount -t ntfs /dev/sdc1 /mnt/
NTFS signature is missing.
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

mycomp@mycomp ~ $ sudo mount -o offset=2048 /dev/sdc1 /mnt/
mount: /dev/loop0 is write-protected, mounting read-only
NTFS signature is missing.
Failed to mount '/dev/loop0': Invalid argument
The device '/dev/loop0' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

mycomp@mycomp ~ $ sudo ntfsfix /dev/sdc1
Mounting volume... NTFS signature is missing.
FAILED
Attempting to correct errors... NTFS signature is missing.
FAILED
Failed to startup volume: Invalid argument
NTFS signature is missing.
Trying the alternate boot sector
Unrecoverable error
Volume is corrupt. You should run chkdsk.

after the suggestion of acejavelin:

mycomp@mycomp ~ $ lsmod  | grep ufs
ufs                    73728  0 

mycomp@mycomp ~ $ sudo mount -t ufs -r -o ufstype=ufs2 /dev/sdc1 /mnt/
[sudo] password for mycomp: 
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
missing codepage or helper program, or other error

In some cases useful info is found in syslog - try
dmesg | tail or so.
          73728  0

mycomp@mycomp ~ $ dmesg | tail -1
[13211.885241] ufs: ufs_fill_super(): bad magic number

Afther suggestion of Andrea Lazzarotto:

testdisk analysis:

Disk /dev/sdc - 250 GB / 232 GiB - CHS 30401 255 63
Current partition structure:
Partition                  Start        End    Size in sectors

Invalid BSD disklabel
 1 * FreeBSD                  0   0  5 30401  80 63  488397164
 1 * FreeBSD                  0   0  5 30401  80 63  488397164

 Warning: Bad ending head (CHS and LBA don't match)

testdisk further analysis:

Disk /dev/sdc - 250 GB / 232 GiB - CHS 30401 255 63
Partition               Start        End    Size in sectors

No partition found or selected for recovery

Even more checks:

mycomp@mycomp ~ $ sudo file -s /dev/sdc
/dev/sdc: DOS/MBR boot sector

mycomp@mycomp ~ $ sudo file -s /dev/sdc1
/dev/sdc1: data

mycomp@mycomp ~ $ sudo mount -t msdos /dev/sdc /mnt
mount: wrong fs type, bad option, bad superblock on /dev/sdc, [...]
7
  • Pretty sure you are chasing the wrong problem, the "FreeBSD" file system means it is likely UFS and not ntfs, continuing to try to "fix" a broken ntfs file system when it is really something could ruin the system or it's data.
    – acejavelin
    Mar 4, 2017 at 16:19
  • I do now remember that about a year ago I contacted Pioneer with the question how I should connect via ethernet to the hard disk recorder in order to retreive the files on the disk. Their answer was: This disk has been formatted so that it works only in the DVR-LX61. As said, I took the disk now physically out the recorder and connected it directly with SATA to my motherboard. Is it possible that the manufacturer has created an own kind of file system? My guess is that the files themselves are not encrypted, it's only not easy to mount it. How should I deal with this?
    – terano
    Mar 4, 2017 at 17:04
  • Specifically, why are you trying to mount it as NTFS? Did you scan it with Testdisk? It should be the first thing to do... Mar 4, 2017 at 23:00
  • @AndreaLazzarotto well, I did try to mount with different fs as mount type; only ntfs gave me a more meaningfull error; all the others (vfat, extX etc) gave the error: "wrong fs type". That's why I assumed ntfs until now. I didn't know the util testdisk. I installed it now. After analysis also testdisk can't find a common file system. My conclusion is: Pioneer used a custom made file system. I'm currently using the script on mikeknoop.com that acejavelin came up with. I'll report back later if I could proceed with that.
    – terano
    Mar 5, 2017 at 14:01
  • Use file -s /dev/sdc1 to check what it is. However, it is extremely unlikely you’ll be able to play the videos file. You may be able to transfer them to a larger disk, but without appropriate library entries, the recorder will most likely ignore them.
    – Daniel B
    Mar 5, 2017 at 14:50

3 Answers 3

1

Been a while since I have done this with *BSD systems... but here goes.

According to your fdisk -l command, the partition's filesystem is "FreeBSD" which if correct is probably UFS, not fat, ntfs, or extX.

First, make sure you have the ufs module loaded with lsmod | grep ufs, if it is not listed, load the module with sudo modprobe ufs

Try to mount is a UFS filesystem

sudo mount -t ufs -r -o ufstype=ufs2 /dev/sdc1 /mnt/

Proceed as normal.

5
  • Hi! it seems also ufs is not the right fs or it is but with an error. I added the results in my question.
    – terano
    Mar 4, 2017 at 16:31
  • Perhaps it's really NetBSD, try changing ufstype=44bsd instead of ufs2.
    – acejavelin
    Mar 4, 2017 at 16:38
  • @terano There are multiple references to the Pioneer DVR's using UFS as it's filesystem, mikeknoop.com/pioneer-dvr-harddrive-recovery-tools is one. I think we are on the right track, unless Pioneer decided to modify this to make proprietary, then it may be possible but it would take manually ignoring errors and setting the correct mount offset, which is beyond my knowledge.
    – acejavelin
    Mar 4, 2017 at 16:41
  • I tried ufstype=44bsd and also 5xbsd, but both with the same result: "mount: wrong fs type, bad option ....etc"; thnx for the link to pages with "pioneer recovery tools". Step 3 of "Manual Recovery" is creating an image file of the disk. Would that be possible without first mounting the disk?
    – terano
    Mar 4, 2017 at 16:56
  • @terano Yes, in fact I think it has to be, or at least should be, unmounted to make an image of it.
    – acejavelin
    Mar 4, 2017 at 18:06
1

I had the same problem. System information here:

--ASUS Zenbook UX430un, --Windows 10 (1903) dual with Ubuntu 18.04

I tried almost every solution on the internet. Finally, by chance, I figured out that the problem is caused by BitLocker on my Asus laptop. I manually turned it off using the solution provided here in windows and after reboot, Ubuntu recognized it automatically and I mounted it successfully. Check if your problem is because of the same issue... Good luck!

4
  • You disabled the BitLocker service or you disabled BitLocker? It’s not clear how disabling a service on an operating system that isn’t running would have done anything. There is no evidence the author was using Windows.
    – Ramhound
    Dec 26, 2019 at 19:01
  • BitLocker is originally set in windows to protect hard drive. So, it doesn't allow another OS access to its partition. Reboot to Windows, disable BitLocker (from here), then reboot to Ubuntu and you'll see that you can mount the partition. Dec 26, 2019 at 20:04
  • BitLocker is full disk encryption. Software exists that allows for decryption on Linux. However, I will repeat the fact, there is absolutely no evidence the author was using BitLocker or Windows. I am extremely familiar with Windows and BitLocker. You should edit your answer to indicate your talking about disabling BitLocker protection instead of suggesting you disabled the service.
    – Ramhound
    Dec 26, 2019 at 20:16
  • Ok, answer edited. Dec 26, 2019 at 20:43
0

Somebody had posted this and it worked for me.

Ubuntu 13.10 or higher

Since Ubuntu 13.10, this package is in the main repository. Just install exfat-fuse and exfat-utils:

sudo apt update && sudo apt install exfat-fuse exfat-utils

Ubuntu 12.04

For ubuntu 13.04 and lower, you'll need a ppa to install the exfat support. Installation procedure:

sudo apt-add-repository ppa:relan/exfat sudo apt-get update sudo apt-get install fuse-exfat

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .