5

Before the Anniversary Update (which I only installed recently), Win 10 Pro 64 had one main account (mine) :

  • Its name was Administrator (it was the built-in admin account)
  • Its full name was different (lets say it was "Full_Name")
  • This account had (obviously) Admin rights
  • Its Win 10 User folder was "C:\Users\Administrator"

And I was very happy with this.

Since applying the Anniversary update a few days ago, Win 10 has changed my User folder to "C:\Users\Administrator.000" and created a new/different "C:\Users\Administrator". I didn't noticed anything special at first since everything appeared fine (desktop icons etc appeared like normal, everything had been silently moved and set up). Privileges are still fine, etc.

But browsing through the Users folder I noticed this change. It's not a big deal in and of itself but for the sake of cleanliness I would like to return the situation to normal, ie :

  • have my user account be the built-in Admin account again ; and thus also...
  • having my User folder be "C:\Users\Administrator" once again (with everything moved back and correctly detected/set in there) and not have this "Administrator.000" be my user account folder anymore

How can I proceed ?

  • It sounds like you may have encountered problems because the default, built-in admin account for managing a Windows 10 workstation is also called Administrator, although it is typically disabled. It that the one you were using, or did you somehow create another account by the same name? – Run5k Mar 4 '17 at 19:20
  • @Run5k : yes, it was the one I was using. I clarified this in the OP. – Parker Lewis Mar 4 '17 at 19:43
  • Thank you for the clarification. When a Windows 10 major feature update is released (1511 or 1607, so far), it is essentially like an in-place operating system upgrade. Because Administrator is a built-in account instead of a user-created login, it basically gets recreated each time instead of migrated. The operating system is appending .000 on the profile to differentiate it from the Administrator account within the "new" OS. If you don't mind me asking, why are you utilizing the built-in account? That is normally discouraged for security purposes, and it also can't run "metro apps." – Run5k Mar 4 '17 at 19:53
  • @Run5k. Mainly for convenience. I'm the only user on the PC and I'm allergic to just not being able to do random stuff easily on the rare occasions I need to. I'm not into deactivating absolutely everyhting I could, but I definitely need ways to significantly reduce Windows refusing to do what I'm telling it to (back in Win 7 days, the first thing I ever did was turning my account into the superadmin). I also have no interest in metro apps. – Parker Lewis Mar 4 '17 at 22:51
  • Those are all valid points, but on my Windows 10 machines I utilize a local login with full admin privileges and a different account name, so the problem you described never occurs. It's a matter of personal preference, but if you do the same and also modify your UAC settings to one of the two lower options, you will probably achieve essentially the same results while avoiding this problem. – Run5k Mar 4 '17 at 22:58
2

I had this problem as well. For me, in my original C:\Users\Username folder one folder remaining in it, Index. When opening this folder in Explorer I was presented with the well-known dialog asking me to grant permission to this folder. I reverted to the previous Windows 10 version, 1709, and then I moved the search index to a different directory, removing C:\Users\Username\Index. I tried the update to 1803 again and now my user directory was not renamed to C:\Users\Username.000.

I suggest that you check if the deepest subfolders of the folders that remain in your original user folder are accessible. If not, you may have the same problem that I had. Revert to the previous version, fix the access problems, and try the update again.

When reverting to a previous Windows version, I advise you to make a USB recovery drive because for me reverting lead to a broken Windows installation once.

  • valuable info, especially w.r.t. the Index. You realize, though, that this is likely a variation on what I outlined already in my answer. Just saying, because you commented on the another answer by me. – 0xC0000022L May 22 '18 at 7:51
  • just to add, this happened to me but the user wasn't Administrator and the "problem" folder was stuff in AppData and not Index, but clearing that, reverting and re-updating fixed it for me – kmdreko Aug 10 at 16:17
0

This typically happens when the old profile path is inaccessible. There are a number of reasons for this such as changing the computer's SID or even the old profile not being properly unloaded or wrong ownership or DACLs. This has been the case since at least Windows NT 4, btw.

With the registry editor of your choice go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\$SID, where $SID is the placeholder for the SID of the account which shows the behavior you describe. You can see which SID corresponds to your account by asking wmic useraccount get name,sid. Typically the one ending in -500 is the built-in (local) admin account and -1000 the first created user account. These numbers (500 and 1000 respectively) are called RIDs (relative IDs).

Inside said registry key locate the value for ProfileImagePath and adjust as needed.

Profile settings for built-in admin

Please note that if the profile still exists under the old path (without .000) and is still inaccessible (say due to ownership or DACLs) you may run into a situation where WinLogon will simply create another new profile (presumably with .001 suffix). Although I have not seen it on modern Windows versions, there's a chance you may lock yourself out by tampering with the ProfileImagePath value, so I suggest you keep a secondary account active and available (e.g. the built-in admin account).

As mentioned, this should be the same procedure for anything from NT 4 onward. However, possible that Microsoft introduced new rules for these Microsoft (online) accounts which you can use. Also the SIDs look different when dealing with domain accounts.

NB: I posted this exact same answer over here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.