I just purchased an iPod Touch. I am having a lot of trouble with its speeds on my Tenda W311R, but it has no speed problems on my neighbor's Netgear router.

It will connect and authenticate to my network, but the Speed Test app from speedtest.net shows rates near 20-50 kbps.
If I run the speed test immediately after powering the iPod on, it will get speeds of 10-20 Mbps, like it should - but the speeds slow down to the kbps range abut 10-15 seconds afterward.

I get the same behavior with encryption and without encryption, and regardless of N, G, or B compatibility settings in the router.

I've tried rebooting the iPod and resetting the network settings, but it's still slow.

I've tried pinging the iPod from another computer, and it shows about 40% packet loss:

$ ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=14.188 ms
64 bytes from icmp_seq=1 ttl=64 time=11.556 ms
64 bytes from icmp_seq=2 ttl=64 time=5.675 ms
64 bytes from icmp_seq=3 ttl=64 time=5.721 ms
Request timeout for icmp_seq 4
64 bytes from icmp_seq=5 ttl=64 time=6.491 ms
Request timeout for icmp_seq 6
64 bytes from icmp_seq=7 ttl=64 time=8.065 ms
Request timeout for icmp_seq 8
Request timeout for icmp_seq 9
Request timeout for icmp_seq 10
64 bytes from icmp_seq=11 ttl=64 time=9.605 ms

Signal strength is good - I'm never more than 20 feet from my access point, and it exhibits the same behavior if I'm standing next to the router.

It works just well enough to receive text, but videos don't work at all. App downloads are hit and miss.

I've tweaked just about all of the settings I can see to tweak, and I'm at a loss.
I have also been searching Google for the past three days, all to no avail.

Any suggestions?

  • It's like it's establishing and dropping the connection over and over. Is this a case of bad behavior in my router? I haven't had any problems on this router with my Dell desktop (Trendnet USB wireless N adapter) or my MacBook Pro. – mskfisher Mar 11 '10 at 14:56

Exactly the same issue, but I have fixed this by downgrading the WT311R+'s firmware to an older version of H1_V3.2.5e-Feb 26 2009 (previously 3.3.5u dated 2010-03-17),as a test I upped the version back to 3.3.5u again & the proble re-appears.

Hope that helps


| improve this answer | |
  • Found a link at tenda.cn/pdtData/update_en/Firmware/wireless/W268R_W368R/…, trying it tonight. – mskfisher Jun 23 '10 at 22:27
  • That firmware doesn't seem to be for my model, since it locked up my router every time I tried it - does anyone know where can I find older versions of Tenda firmware? – mskfisher Jul 12 '10 at 12:04
  • Giulio's download link worked - but I'm marking yours as the answer since you identified the problem first. Thanks! – mskfisher Apr 7 '11 at 12:19
  • Odd behavior after 24 hours - some performance quirks showed up (Facebook, Twitter apps wouldn't load), but once I power cycled the router, all was back to normal. Weird? – mskfisher Apr 8 '11 at 2:15

I confirm Tony's solution also on W311R. It works much better after downgrading firmware to 3.2.5e.


| improve this answer | |
  • I finally managed to successfully install this firmware, and things do seem to be better. Thanks! – mskfisher Apr 7 '11 at 12:16

As the W311R+ is vulnerable to brute force attack against WPS with the old (H1_V3.2.5e-Feb 26 2009) firmware, I prefer firmware version H1_V3.3.6d_EN-Jun 17 2010, that both works with iPod and has ability do disable WPS permanently.

V3.2.5e cannot disable WPS (even if disabled+saved in settings) - WPS is automatically enabled after reboot/power off) and W311R+ becomes vulnerable.

V3.3.6d with WPS disabled is resistent to attack for exaple using reaver, see this reference.

| improve this answer | |

On a whim, I tried connecting my old 802.11g Netgear router to the Tenda to create a separate wireless network for the iPod to connect through.

Sure enough, after doing the requisite IP and DHCP router-to-router configuration, the iPod/Netgear combo is working like a champ.
Consistent 4500 kbps down and 2500 up.

Besides the few extra watts it takes to run two routers, I'm pretty happy with this solution.

| improve this answer | |
  • I actually posted this from the iPod just to savor the victory. :-) – mskfisher Mar 20 '10 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.