I have installed Ubuntu such that it is split into 2 partitions (mounted as / and /home)

After running sudo apt-get install vlc, I get the following error on a near fresh install of Ubuntu 16.04.2 LTS (Xenial Xerus).

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
E: Unable to correct problems, you have held broken packages.

What would be the easiest way of correcting the problem?

I have tried sudo apt-get clean, sudo apt-get update, and sudo apt-get dist-upgrade before running sudo apt-get install vlc again.

I have also tried to install libgles1-mesa with sudo apt-get install libgles1-mesa but returns with an error (see linked question)

I'm not sure if this is possible, but can I just reinstall the core Linux files to the / partition from the original installer (that I still have) and hope that libgles1-mesa appears?
(without losing any of my files or application settings)

Note: I appear to be having the same problem as the OP of https://askubuntu.com/q/889356/ but the Ubuntu versions differ.


2 Answers 2


In my case there were 2 repositories in source lists containing vlc packages:

  1. Official vlc repo ppa:videolan/stable-daily;
  2. Ubuntu universe repo.

In first repo there were newer vlc packages, so sudo apt-get install vlc caused installation from first source.

The solution was to purge all packages from first source and remove this source list

sudo apt-get update
sudo apt-get install ppa-purge
sudo ppa-purge ppa:videolan/stable-daily

Next install vlc from Ubuntu Universe repo

sudo apt-get update
sudo apt-get install vlc

In case that you had problems with unmet dependencies like I did, there is solution to add PPA ffmpeg-4 and then you will be able to install it properly:

sudo add-apt-repository ppa:jonathonf/ffmpeg-4
sudo add-apt-repository ppa:jonathonf/vlc-3
sudo apt-get update
sudo apt-get install vlc

Source: https://launchpad.net/~jonathonf/+archive/ubuntu/vlc-3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.