5

I have this very annoying problem :

Whenever I want to create or edit a folder on my system it takes a very long time to complete. Right click-new folder... wait... wait... wait a good 30-60 seconds then type name and enter... wait again 30-60 seconds and then you can enter it.

Browsing is normal and I have no problem creating folders through applications like eclipse but through explorer it is a real pain. Renaming folders has similar effect.

otherwise the computer is (almost) normal,

any ideas?

  • using any anti-virus or OSS software? – stim Mar 11 '10 at 7:58
2

Try creating a new user and test if the same behavior applies to it. A new user profile comes with a clean CurrentUser registry hive (a db file containing a lot of program settings) and less added extensions which apps usually install for current user (the user profile with the issue) while leaving other user profiles alone.

If the issue happens on the new user as well then the issue might be hardware related, mostly random reads/writes, RAM failure, HDD failure, mainboard failure, cable failure. The best you can do is to defragment the HDD / secure erase the SSD (first backup the OS using a full system imaging software like TrumeImage, TeraByte IFW or alike, then secure erase the drive - this will reset the SSD's data structure to unprogrammed, like it were new, then restore the backup). This does not guarantee fixing.

If the new user profile has no issues creating folders fast, then you'll have to look at several other places.

Use Sysinternals Autoruns utility to disable any unnecessary context menu handlers, by unticking them. Look for *...\ContextMenuHandlers under the Explorer tab in Autoruns utility, which are the ones applied to the surface of any folder, when clicking empty space and subsequently loading all components when all that is needed is the New -> Folder entry. If components are the cause, the New -> Folder entry should show up quickly.

If this doesn't fix the issue, restore the components by ticking them back to their initial state. If the are unticked from the start leave them so.

User Nirsoft ShellMenuNew to disable new context menu handlers, works on the same principle as Autoruns. If this doesn't fix the issue, restore all of just what you need.

Try looking at registry's BagMRU entry, it's the place where every time you open a folder it creates its settings and views as setting strings in the registry.

It's an immense fup on ms part, and over time this thing becomes about 1/2 of the registry's size. This usually also slows down folder browsing, if once cached when accessed for the first time in a session it won't affect viewed folders later, unless it gets uncached by the explorer.exe process. Open the registry (run > regedit, or use something like Registry Workshop application), navigate to: [HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]

You can delete this whole key, but export it first as a backup (right click, export, give it a name, save as reg).

The only thing you need to recreate is the Key BagMRU and the size value "BagMRU Size", a DWORD of whatever yours is, mine is a 5000 decimal. Everything else will be recreated once you'll browse folders, but you'll lose current folder settings (views and icon sizes).

For noobs, recreate a blank BagMRU key:

  1. have Shell key selected in the right tree layout of the registry, right click new -> key in plain area on the right of the tree, give it the name BagMRU instead of New Key #1 and press Enter

  2. have BagMRU key selected in the right tree layout of the registry, right click new -> DWORD (32-bit) Value in plain area on the right of the tree, give it the name "BagMRU Size" without the quotes instead of New Value #1

  3. double click BagMRU Size, select radio box Decimal and enter 5000 in the Value data: field.

  4. since you're noobs, a good way to see if all worked fine is to logout and login again, if the new folder procedure works fast then that's where the issue was, if not kill main explorer from task manager and re-run explorer.exe.

If you can't figure it out, but did export the old one, find the reg file and double click it to add its contents back to the registry.

The unlikely but still could be the issue - antivirus application (AV for short) on slow/old systems.

Try lessening AV's scanner settings, less heuristics at first, test with and without "on creation" event, if it allows so. If not, then probably it's not it. This one doesn't come with detailed instructions for noobs because you need a medium level of understanding what these settings are so that later on, if a wannacry trojan hits you, you won't complain that the guy on superuser said to do it leaving your system vulnerable. Best is to ask the windows guy next door for help.

| improve this answer | |
  • Thanks, I had completely forgotten about this question. I did solve my problem and it was a context handler that pointed to a defective piece of software (timeout at construction).removing this link and everything got back to acceptable performance. I would create my own answer but your answer covers my case so (Rubber stamping bam). – Newtopian Apr 7 '15 at 16:24
  • I see this answer is checked as accepted. I have this same problem, but I don't understand half of this things in your solution. And you use a lot of jargon and acronyms. Could you rework your solution and add understandable directions for anyone to follow? This would be most helpful. Thanks. – ejbytes Jun 12 '17 at 16:59
  • Well ejbytes, you could always ask for clarification on the part you don't get in the comments section. You know, this site is not a howto site like wikihow. Basic and medium understanding of the OS in question is required. – JasonXA Jun 28 '17 at 1:19
1

You can try to research that behaviour using Process Monitor. Try to monitor explorer.exe with that tool. Collected logs can give a hint what might be slow there.

| improve this answer | |
  • I did check with Process Monitor and found nothing in particular but I will check again more thoroughly and dig down to threads and handles. Maybe install the debug symbols too and get more meaningful logs. – Newtopian Mar 12 '10 at 2:04
1

Ok... Maybe this is a loooong shot, but it works for me: is your computer rarely turned off? Maybe you're using Sleep / Hibernate and explorer.exe gets confused and slow after waking up.

I was having the same problem and, as it is VERY annoying, I've set out for answers. At this forum I found this reference to explorer.exe:

  1. In an Explorer window, make the Menus visible by clicking Organize - Layout - then checking Menu bar.
  2. Now click the Tools menu and select Folder Options...
  3. Click the View tab.
  4. Scroll down and check [ ] Launch folder windows in a separate process.

This is confirmed as a solution to me. Creating folders or renaming them took as long as 3 minutes before this procedure (also moving files required a refresh - F5 - to be performed before changes could be seen). Now it is instantaneous.

| improve this answer | |
  • Doesn't help in my case with Windows 8 x64 – Vladislav Rastrusny Dec 2 '14 at 5:49
  • @FractalizeR it is probably a completely different issue on Windows 8. This solution was for Windows 7 x64 as asked by the OP. :) – marquito Dec 9 '14 at 10:27
  • Yeah, probably ;) – Vladislav Rastrusny Dec 9 '14 at 10:34
  • 1
    This fixed the problem for me on 64-bit Windows 8.1 Enterprise. Note that I, too, almost never shut off my computer and instead use 'hibernate' a lot. – Matthew Jul 9 '15 at 19:18
0

run a disk check and ensure integrity of the file system. if it only happens with directories with a lot of files, it might be your antivirus scanning the folders.

| improve this answer | |
  • Ordinarily, I'd suggest that answers be reserved for definitive solutions, and comments used for helpful hints and speculative solutions. However, there are so many bad examples in this thread, it would be a double standard. – fixer1234 Apr 7 '15 at 0:52
0

This is a known issue with varied solutions. This is likely cause by some misbehaving context menu (right-click menu) providers. These context menu providers might listen to folder create/rename events but not respond correctly or fast enough to Windows Explorer causing delays/pauses. Installing new software typically installs its own set of context menu providers which might slow things down.

  • One way of solving this problem is by using trail & error methods of disabling some of the context menu items and shell extensions using tools like NirSoft ShellExView and NirSoft ShellMenuNew

  • Microsoft has also released a stability update that might solve this problem: KB980408. Under the heading "Issues that this update fixes" it states that one of the issue KB980408 fixes is: "Windows Explorer may stop responding for 30 seconds when a file or a directory is created or renamed after certain applications are installed"

| improve this answer | |
-1

I think System Restore will come into play in this situation.Restore your pc to the time these functions were working fine.

| improve this answer | |
  • 1
    Please provide more information on how System Restore would solve the author's issue exactly. – Ramhound Feb 5 '13 at 12:19
  • let him ask first if he knows how to do it he'll do it if not he will ask for it. – Franco Feb 5 '13 at 17:39
-1

I recently fixed this on my computer:

open IE -> Preferences -> Internet Options -> Connections tab -> click LAN settings button and uncheck box next to Automatically detect settings and click OK.

enter image description here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.