2

Since the last couple days, Steam has been refusing to go online. Previously, I've had to launch Steam offline and then tell it to restart in online mode to actually make it go online but something in it decided to not launch at all anymore. I've already been browsing some article here, here, and here. The fixes I've already tried are as follows (in order):

  • Uninstalled steam using steam uninstaller
  • Removed steam data from installation directory “C:\Program Files (x86)\Steam”
  • Removed steam user data from “AppData\Local”
  • Cleared temporary data
  • Removed all steam\valve registry keys
  • Updated wireless drivers
  • Cleared dns cache “ipconfig /flushdns”
  • Reset winsock catalog “netsh winsock reset”
  • Reset TCP/IP stack “netsh int ip reset”
  • Reset TCP protocol “netsh tcp reset”
  • Rebooted
  • Updated windows to latest
  • Repaired VC redistributables
  • Repaired .NET redistributables
  • Disabled all antivirus
  • Disabled firewall
  • Reinstalled steam
  • Repaired steam client service
  • Ran steam as administrator
  • Ran steam in compatibility mode for both Windows 7 and 8.

Since then, I've also gone to a different internet connection, where the issue still persists. I've also created a new user profile for testing steam, and given it full system administration rights (equivalent to a core system service). Even after all this, the issue still persists. Some of the final fixes I see would be to - use an ethernet connection in case some wireless protocol is causing the issue; reinstall/reset windows entirely; test if steam connects in safe mode with networking to eliminate any software conflicts.

For reference, I'm running Windows 10. The wireless card I have is an inbuilt Intel Dual-band Wireless-N 7260 - I am indeed running on a laptop here. The current driver version is 17.15.0.5 and I have not seen a more-recent version to date.

Does anybody has any solutions, tips, or anything they think I could try to get steam working (bar a full windows reinstall) online again?

2

SO I open Steam again this afternoon, I figured I'd just refresh my IP stack one more time... and now it's logging in and working as expected. Steam is weird. This is confusing. I'll reopen the question if it stops working again.

UPDATE: After this happened a couple times more, I've done some more investigation into the issue. It seems that the Steam login servers don't play well with an unstable, or packet lost network. When this occurred again, I decided to check my router console and the state of my connection - the connection had tanked to a SNR margin of 23.1dB from a standard 6dB, with an attenuation of around 32dB. As a result the link speed was about 600kBps (~75kb/s).

However, to further investigate the issue, I decided to leave the router on, and instead logged in with my mobile data. After I had successfully logged in with my mobile data (which worked instantly), I reconnected to my router without restarting Steam. Once I had connected to the router, Steam automatically reconnected again and worked absolutely fine (despite the very bad link speed). I then exited Steam, and tried to reopen it - the login failed, saying it couldn't connect to the Steam network. I restarted my router, with the connection now at an SNR of 6dB, and attenuation of 64dB, and a link speed of 3.8mBps (~475kb/s). With the new connection, I launched Steam again, and it successfully logged in.

TL/DR Steam login servers don't like slow connections, connections that loose packets, or unstable connections in general. Once Steam has logged in however, Steam works happily with said connections.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.