10

If I am doing nothing for about 10 minutes or so, then my OS is locked and I have to login again which is very annoying. How can I disable this security feature?

9

Another solution is to increase the sleep to it max

Settings > Power Manager > Security

unchecked Lockscreen when system is going to sleep

enter image description here

1
  • This is the solution for the latest version on Jan-2020 – Daniel Garcia Jan 25 '20 at 10:33
6

I had the same problem and solved it one hour ago. Here is how I did it:

In the drop-down Application-menu choose:

Usual applications / Preferences /Settings

This opens the window All Settings. Here, click on

Privacy (top row, 4th icon from the left),

which opens another window, where you click on the

top item in the table, to open even another window!

Now you finally can switch the screen saver off completely or choose another time span.

2
  • I couldn't find "Preferences / Settings" under Usual applications but I did a global search for "Settings" and found it that way. Then found Privacy. Thanks. – Mastro Oct 15 '17 at 12:58
  • I can't confirm if this works right now, since I am not using Ubuntu anymore. – Black Jun 19 '18 at 10:19
4

Problem

Kali Linux keeps locking the screen when not used for a short period of time

Solution

You need to configure "Light Locker" to stop automatically locking the session.

Steps

Disable Screen Lock in Kali Linux 2020

  1. Click the icon at the top left of the screen (Kali Linux Logo)
  2. From the popup menu, click "Settings"
  3. From the next popup menu, click "Power Manager"
  4. Confirm that "XfcePower Manager" window has opened
  5. In the "XfcePower Manager" window, click the tab "Security"
  6. From the "Security" tab:
    • Change drop down "Automatically lock this session" to "Never"
    • Uncheck "Lock screen when system is going to sleep"

source: https://brakertech.com/disable-screen-lock-on-kali-linux-2020/

1
  • 1
    Thanks for your effort to describe the solution nicely. – UtpMahesh May 28 '20 at 10:33
2

As the question is a bit old now, latest versions of Kali should have Settings located in the top right-hand corner of the screen when you click the down arrow. Then click the tools icon on the bottom left of that menu.

Alternatively, if in gnome GUI (default) you can use the following command in terminal to launch settings:

gnome-control-center

Once in settings, screen lock is located under Privacy on the left menu.

1

I was having the same problem. Just a bit easier, search for privacy and click on the privacy "link". Change the Screen Lock time or turn it off.

1
  • fantastic, after a reorganization of the the screen, the answer through Application-menu is not available in the latest Kali, but yours is generic and still worked. – Peter Teoh Feb 14 '18 at 1:52
0

After changing files in this folder path works for xfce4 /usr/share/backgrounds/kali/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.