2

Not owning a magic mouse, I'm moving between spaces by using the combination ^+ and ^+

Things worked properly until I have a virtualbox window being on full screen mode, which takes whole new space. The combination above keep moving spaces then it stops when the mouse (or keyboard?) get focus inside the virtualbox window.

I had to click outside the virtualbox window (by clicking on my 2nd monitor) then hover the mouse over the virtualbox window and re-apply key combination to move spaces.

So, is there a configuration of virtualbox or on macOS to keep moving smoothly between spaces even when there is a virtualbox space.

Edit on Dec 24, 2018

The same thing happens on i3wm, the mod+#number is captured by the box instead of the host. So Gonzalo Lucero's workaround helped!

2
  • try 3 or 4 finger swipe to right and left.
    – kholis
    May 9 '18 at 6:41
  • @kholis 2 fingers would get it done with apple magic mouse, but did you really mention about the regular mouse? May 11 '18 at 6:37
7

You can press the Host key to 'release' the mouse and keyboard. This will then allow you to use your normal mac keys to switch between spaces.

The trick is to press the Host key once and separately before any key combination. This was the bit that always got me at first. After some time this action will become second nature. It will be just as quick and as smooth transition as when virtual box is not running.

By default my Host key is Left ⌘ and I move between spaces with Ctrl left or right.

So even when I am in my virtual machine full screen I press:

'Command ⌘' ; and then
'Ctrl' + 'left arrow'

And done!

3
  • awesome @ipolevoy. great to know. Nov 28 '18 at 20:08
  • wow thank you! Now I can have my VM in 'true' full screen with out any mac toolbars. excellent!
    – Robeezy
    Aug 10 '19 at 20:46
  • no worries @Robeezy Sep 4 '19 at 0:07
1

In short, no.

If you're inside a VM which uses those keys they will 'steal' them. The same applies to Remote Desktop apps, Microsoft or Apple.

Your options are

  1. Change the key combo in either the VM or Mac

  2. Use the 'direct to this Space' keys instead, which are Ctrl ⌃ [number] by default, but not activated by default.
    System Prefs > Keyboard > Shortcuts > Mission Control
    Enable the Switch to Desktop options.
    Note that if you have a keyboard with a 10-key numberpad, the OS treats the 10-key differently to the 'qwerty' numbers & they are defaulted to 'qwerty' (though there's no way to identify which it's using except to try it)
    Also note that fullscreen Spaces don't have a number, so to get to those you'll need to go back to your Ctrl ⌃ or method [one reason I never use fullscreen].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.