4

i installed a new Debian on a small VPS and now when i try to install sudo i just get this message. I also tried to add FTP-Server into the list and i still get that error.

root@srv45758:~# vi /etc/apt/sources.list
deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
deb http://ftp.de.debian.org/debian/ main contrib non-free
deb http://security.debian.org jessie/updates main contrib non-free

Does any one maybe know the problem?

3 Answers 3

5

Verify your sources here

Try using apt-get install sudo to get it.

You can configure users to use it with its config file:

vi /etc/sudoers

add a line:

user ALL=(ALL) ALL
3
  • I was trying to install it with apt-get install sudo
    – Janlasse
    Mar 10, 2017 at 15:32
  • 11
    @Janlasse Try running apt-get update first to synchronize package lists.
    – Marek Rost
    Mar 10, 2017 at 15:41
  • @MarekRost Thanks this works for me. After updating I'm able to install sudo. Apr 26, 2019 at 16:23
1
apt-get update
apt-get install sudo
2
  • 1
    Code without any explanation is useless. Can you elaborate on this a little more?
    – Toto
    Jan 13 at 22:15
  • these commands are self-explanatory, you may google and post a question on which part is not clear.
    – Vishrant
    Jan 13 at 22:54
0

add to /etc/apt/sources.list

deb http://deb.debian.org/debian stretch main
deb-src http://deb.debian.org/debian stretch main

and run su && apt-get update. now open new shell and itll be available

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.