4

I have a 100 Mbit/s router and all devices until recently were connected to it, so I was only getting 100 Mbit/s connections which makes sense.

Now I've disconnected all my devices from the router, added a 1 Gbit/s switch, connected the router and switch, and connected all other devices to that switch. On the switch I have two computers with 1 Gbit/s adapters and two connections which are 100 Mbit/s, one goes to a second router which acts like a hot spot. Why am I getting a 100 Mbit/s connection between computers with 1 Gbit/s adapters?

Shouldn't the router now handle 1 Gbit/s between the two? Is it possible that the switch is detecting the 100 Mbit/s router connected to it and as such throttling the connection?

Hardware:

  • Router #1: Asus RT-N12+
  • Router #2: TP-Link TL-WR1043ND
  • Switch #1: Linksys SE2500
  • Both PCs: Intel Gigabit Ethernet Adapter

I've also checked all cables. They are Cat 5e.

To better explain my situation here is my setup:

Enter image description here

SOLUTION: The problem was in connectors where not all pins were pushed all the way in.

  • 1
    "Why and I getting 100mbit connection between computers with gigabit adapters?" What do you mean exactly? What precisely makes you think you're getting a 100Mbit connection? Are you looking at the link lights on the switch? – David Schwartz Mar 10 '17 at 20:14
  • 1
    First off windows says its 100mbit under adapter status, second, I'm getting constant transfer speed of 11.5MB/s which would indicate a 100mbit connect, no? I've hooked the two PCs directly over a cable and manually set their IP to test the transfer and it went above 50MB/s. – Eric Mar 10 '17 at 20:16
  • @heavyd I did mention all my cables are cat5e. – Eric Mar 10 '17 at 20:17
  • What do the status lights on the switch tell you? (linksys.com/us/support-article?articleNum=142856) – heavyd Mar 10 '17 at 20:18
  • 2
    @ErikKralj Are the cables (between the switches and the devices that should be running at gigabit speeds) homemade or professionally made? Are you 100% certain they are wired correctly for gigabit? How long are they? – David Schwartz Mar 10 '17 at 20:20
8

The problem is likely in your cables. 1000BASE-T (gigabit ethernet on UTP) requires all four pairs of wires in the cable be connected correctly. If they are not, auto-negotiation will cause the interface to step down to 100BASE-TX (fast ethernet on UTP).

If even one of the two cables connecting the two 1000BASE-T PCs is not correct, then the two PCs will only be able to communicate with each other at 100 Mbps.

  • 1
    It depends on the scheme you are using. Look for T568-A and T568-B. You should use the same scheme on each end. – Ron Maupin Mar 10 '17 at 20:21
  • 1
    Look here and follow the straight thru 568B wiring. – David Schwartz Mar 10 '17 at 20:21
  • 3
    It is entirely possible that you have one bad wire out of eight. There a many crap cables sold, and it is easy to mess up on do-it-yourself cabling (using solid-core cable with connectors designed for stranded cable, etc.) – Ron Maupin Mar 10 '17 at 20:29
  • 2
    When this topic comes up, I like to add that cheap cable pinout/continuity testers are useful up to a point, but can't tell whether you got the twisted pairs right. Note that pins 3 & 6 need to be in one twisted pair, and pins 4 & 5 need to be one twisted pair. If you've already visually inspected the terminations on both ends of all your cables to ensure they're all T568B, then a typical cheap RJ-45 pinout/continuity tester is a convenient way to test continuity of each pin. – Spiff Mar 10 '17 at 20:41
  • 2
    @RonMaupin So today I took another look at all connectors, they were wired correctly, however I noticed some of them were not pushed all the way, so I clipped all of them, redid them and now I'm getting gigabit speeds, thanks to everyone for pointing me in the right direction. – Eric Mar 11 '17 at 14:19
1

I had a similar problem. My issue was that the Cat 6 cable from the RJ45 wall socket to my PC was too close to some power supplies. As soon as I moved the power supplies away Windows negotiated 1 Gbit/s speeds with no issue.

I spent hours trying to "repair" my drivers and configuration thinking it was a software issue.

  • 1
    What? This makes no sense I'm pretty sure there was a wire from socket to pc that was slightly needed modification or spreading . Have you tested with cable tester? – Elie Mar 10 '17 at 23:49
  • 1
    @Elie I suppose it's possible, but it would practically require both the cable and PSU to be utter garbage. – Michael Hampton Mar 10 '17 at 23:58
  • @Elie @Michael Hampton The only thing I changed was moving the power supplies away. It baffled me at that point, but I did not own any cable testers to check anything with. The cable is maybe 30ft and looks cheap, but not total trash. I initially tried testing with my linux laptop sitting under my desk. ethtool eth0 reported that 1Gbit/s was not supported by the link partner. With the cable coiled next to the wall socket 1Gbit/s worked fine. At that point I guessed something was causing interference along the way and moved a laptop and trashy usb 3.0 hub power supply that were touching it. – Kevin Mar 11 '17 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.